Rover-4.1.3 released!

Rover-4.1.3 has just been released as the official version for cars and boats. The changes vs 4.1.2 are in the release-notes and copied below:

  1. Enhancements
    a) CUAV-X7 servo voltage detection support
    b) Support for IIM-42652, ICM-40605 and ICM-20608-D IMUs
  2. Bug fixes
    a) Debug pins disabled by default to prevent rare inflight reset due to electrostatic discharge
    b) EKF3 reset causing bad accel biases fixed (never reported on a user vehicle)
    c) Main loop delay fix for boards with 16 bit timers (affects KakuteF4, MatekH743, MatekF405, MatekF765, SpeedybeeF4)
    d) Polygon Fence upload fix when replacing fence with one that has fewer points
    e) RC protocol detection fix that forced PH4-mini users to powerup autopilot before transmitter
    f) SmartAudio high CPU load fix (previously it could starve other threads of CPU)

In general these are pretty minor fixes but perhaps 2e is the most likely to affect users. It could cause of SBUS receivers to only work if the transmitter was switched on after the autopilot which was annoying.

Thanks and Happy New Year!

2 Likes

Thank you for your update

Happy New Year!

1 Like

I am running rover 4.1.3 and face the following problem: since update skid-steer does not work. (throttle-left/right) does not generate any output

this also happened on the 4.1.3-rc1

@Peter_Loeffler,

Thanks for the report. Is this a new vehicle or did it work with an earlier 4.1.x release? By the way, you can go back to 4.1.2 using MP’s Install Firmware screen’s “All Options” button and then select the version, autopilot and frame. For example, this is what I would select to load Rover-4.1.2 for a CubeOrange.

If you could post an onboard log file that might help us figure out what is going on.

it worked with 4.1.2
I ran into the same problem when 4.1.3-rc1 was announced and went back to 4.1.2 then

1 Like

@Peter_Loeffler,

I just check using my own AION robotics skid-steering rover and 4.1.3 seems to work so this means that the issue is not a general problem and we need to narrow down a bit more.

Providing an onboard log will give me a lot of information to help narrow down on the issue including which autopilot is being used, the protocol being used to control the ESCs, etc.

If the vehicle can’t be armed then setting LOG_DISARMED = 1 will produce a log even if the vehicle is disarmed. If you haven’t downloaded logs before then there are two methods described on this wiki page:

  1. plug a USB cable into the autopilot and download using MP’s Data page’s Data Logs tab’s “Download DataFlash Log via MAVLink” button
  2. pull the SD card from the autopilot, insert it into your PC (maybe an adapter is required), pull out the last log from the APM/Logs directory.

Have had no issues with skid steering on any recent release. Seems a correlation/causation error.

1 Like

sorry for log delay
glad, that it is no general problem but more a “user-caused-phaenomenon”

will provide a log-file in some days

but thanks for your kindness and time so far

peter