Rover-4.1.1-rc1 available for beta testing

Rover-4.1.1-rc1 has been released for beta testing and can be downloaded using the ground stations’ “beta firmwares” links. The changes can be seen in the release notes and they are also copied below.

  1. EK3_PRIMARY allows selection of which EKF core/IMU to use on startup
  2. Bug Fixes
    a) MAVFTP init fix (could cause slow parameter download)
    b) Scripting fix when logging strings
    c) Serial flow control fix (affected at least Lightware LW20 serial lidar)
    d) QiotekZealotF427 IMU (ICM42605) orientation fixed

As you can see, this is a small release mostly to keep Rover inline with Copter and Plane so we can largely rely on Copter and Plane users to uncover any issues but in any case all feedback is greatly appreciated!


on my Matek H743 (BDShot) the 2nd IMU (MPU6000) is not detected any more.
Back to 4.1.0 and 2nd IMU is there again.

Hi @RainFly,

Thanks for the report. Is this repeatable? For example if you go back and forth between the versions you see consistent behaviour? If you’ve got a couple of logs files that would be great.

In any case, I’ve added this to the 4.1. issues list. Txs again.

Hello @rmackay9
Yes, it is repeatable.
I’ll try to get some logs in the next days.

1 Like

Hello @rmackay9
here are some short logs recorded during poweron with LOG_DISARMED=1
It looks like two logs were recorded. Here are both of them: (477.7 KB)

Here is another discussion about IMU1: Matek H743-Mini IMU1 (MPU6000) not recognized

2nd IMU on Matek H743 is detected again after changing INS_ENABLE_MASK 3 → 7


Thanks for the update. I heard this as well from Tridge.

So I guess the issue has two parts:

  • Somehow the INS_ENABLE_MASK on these few boards was set specifically to 3 instead of being left at the default. If it had been left at the default value then it would have changed automatically to “7” or perhaps “127” (I’m not sure which) and all the IMUs would have appeared
  • When adding support for a new IMU that perhaps the manufacturer is planning to add support for (I’m not totally sure of their plans) we probably should not have changed the meaning of the bits of the INS_ENABLE_MASK.

So, I’ll mark this item as closed (on the 4.1 issues list) if that’s OK. Thanks for bringing this issue to our attention.

The “somehow” for me was because I set it to 3 not understanding how the parameter functioned. I was working on re-prioritizing the primary IMU to 1 (from 0) and while reviewing all related parameters set this to 3 manually thinking there are only 2 IMU’s on this FC why are 3 “enabled”.

I understand now!

1 Like

I know this, I gave it as an example of why this parameter if not left at default (127) can now introduce a problem with the other Matek H743 FC. Just leave it at 127.
See here:

1 Like