Rover-4.1.0-rc2 released for beta testing

WARNING: numerous reports of telemetry connection issues have been reported with this release. -rc3 will be released within the next 48 hrs with a fix so we recommend waiting for -rc3

Rover-4.1.0-rc2 has been released for beta testing and can be downloaded from the ground stations (MP, QGC) using their beta firmware links.

The changes vs -rc1 are in the release notes and copied below

Changes from 4.1.0-rc1

  1. Enhancements
    a) Log download speeds improved on F765 and F777 based boards (USB buffers increased)
    b) Serial port DMA contention heuristics improved (reduces chance of delays writing to serial devices)
  2. Bug Fixes
    a) CRSF frame timeout increased to reduce RC failsafes
    b) Declination automatic lookup rounding fix (caused inaccurate declination in some parts of world)
    c) DShot (bi-directional) support on Pixhawk4, CUAVv5, CUAVv5-Nano
    d) IMU semaphore fix to avoid occasional corruption
    e) QioTek Zealot F427 GPIO pin fix
    f) Replay/DAL RMGH log message format fix
    g) Rangefinder initial buffer size and baudrate fix (affected Aintein US-D1 radar)

Let me just say I’m sorry for pushing out yet another release candidate when I think we are all satisfied that Rover-4.1.0 is “fully baked” and ready to become the stable version… the only reason I did this is because it saves administration time if I keep the Rover and Copter releases in sync and an official release requires a bit more time than I had available today.

The changes are all relatively minor and are in areas shared with the other vehicles so we can trust the Copter and Plane beta testers to test these for us.

… so assuming nothing unexpected happens I’ll release this version as Rover-4.1.0 stable within a week. If anyone puts it on a vehicle and gives feedback that is greatly appreciated but no huge pressure.

Thanks again to all who have beta tested Rover-4.1.0!



Hi @rmackay9, just wondering if you saw my query I posted on the rc1 thread regarding a possible issue with ppm into a Matek H743 wing board?

If it is an issue and not just me missing something it’d be great to get a fix into Rover 4.1 stable.

Have pasted my original post below….

I might have found an issue with Rover-4.1.0-rc1 running on Matek H743-Wing failing to accept PPM inputs.

If I don’t change my setup at all other than load the current stable version of Copter, I get PPM input showing in QGC / MP. I’ve also verified the PPM input is working another way by plugging the PPM wire into an old APM 2.6 I had knocking around running some old version of Rover. Both work fine.

These tests lead me to think the issue might be in Rover-4.1.0-rc1 - Is anyone able to replicate this?

Thanks to everyone who’s worked on this release, amazing steps forward. Also can’t wait to try S-curve when that’s up for testing!

check that you have BRD_ALT_CONFIG=0. If it was set to 1 then PPM wouldn’t work.
Otherwise please post a log or it working with copter beta and a 2nd log of it failing with rover

THANK YOU!!! I can’t believe I missed that. I’d used BRD_ALT_CONFIG=1 when experimenting with CRSF so that was the issue.

One of the reasons I didn’t think that was the issue is that I couldn’t find anything online (rover wiki, forums, matek documents) that said BRD_ALT_CONFIG=1 will prevent non serial control signals from being accepted on RX6. What is the correct way that insights like this are recorded for the benefit of the community? Can we suggest Wiki changes anywhere? Previously I’ve tried to make a post on this forum to explain the problem and fix but not sure if that’s the best way to go about it.

Thanks again