Rover 3.5.1 released!

After a few weeks of beta testing Rover-3.5.1 has been released as the official version. This version is the same as 3.5.1-rc1 (except for the name). The changes can be seen in the ReleaseNotes and they are also copied below.

Changes from 3.5.0

  1. WHEEL_DISTANCE mavlink messages sent to ground station and companion computers
  2. Bug fixes:
    a) EKF compass switching fix for vehicles with 3 compasses
    b) Guided’s heading-and-speed controller no longer uses lane based speed control
    c) Pre-arm check fix that all required motors for the frame are configured
    d) Prevent loss of active IMU from causing loss of attitude control
    e) Added startup check for Hex CubeBlack sensor failure
    f) don’t reset INS_ENABLE_MASK based on found IMUs

We didn’t get a lot of feedback on beta testing but hopefully everything will be OK. Please reply below or create a new topic if you find issues, thanks!


Hi Randy!

Just upoaded 3.5.1 on my pixhawk for rover and f find out the same issue as in this thread. There are no any options available for auxiliary ports (rc7, rc8, rc9 opt)

Re-upload previous 3.4.2 version of rover, and everything is working fine.
Mission planner installed the latest stable version 1.3.66

Do you know to fix this issue?

Update Mission Planner to latest Beta. Questions like these come up all the time and it’s usually the case that MP is a bit behind the firmware Rev. Or in all cases get in the habit of just using the Full Parameter List then the problem goes away.

Note the rev levels here:


coudl you please send a link where to download latest beta version, accoring to this, it’s only previos version 1.3.53 not 1.3.66 1.3.7070

From within MP, select the Help menu at the top of the window, then click the “Check for BETA Updates” button on the bottom middle…

1 Like

Thank you, find it, it helps

1 Like

First of all I’m a new newbie. I installed 3.5.1 for a Rover (MP1.3.66) and have been tearing my hair out all day. Yes the RC 7-9 boxes are greyed out, but you can set the value of RC7 to 41 in the full parameter tree. I got it to work for arming. My problem is getting either the throttle or steering(servo) to respond. The values are set properly in the servo functions. My question is do I have set a value for RC1 to get it to actually send a signal to the steering servo? If so, what is the value.



Inputs and outputs are separate and it is probably best to test that they work correctly separately.

For the outputs it’s best to use the motor test screen. If the steering servo or motor doesn’t move (I assume this is an ackerman steering vehicle - i.e. separate steering and throttle outputs) then it’s an output issue and it would be good to check the SERVO_ parameters or the vehicle’s ESC or servo.

For inputs it’s best to look at the RC calibration screen and make sure the green bars are all moving in the same direction as the physical sticks except for the pitch stick where the green bar should move in the opposite direction from the physical stick. If any green bars don’t move in the correct direction, it’s best to modify the configuration in the transmitter itself.

Hope that helps some…

Does this version support in-flight compass learning?

1 Like


No I’m afraid it doesn’t. This will be included in Rover-3.6 which is still only available from “latest”. So you could give it a try by going to MP’s Install Firmware screen and press Ctrl-Q but it’s untested really.

The big feature I’m keen we include in the next version of Rover (and Copter for that matter) is better object avoidance. That’s under active development so I’m sure we will have something. Here is a very rough video of “bendy ruler” being tested on Rover over the weekend.

1 Like

did update to beta but can’t update

And I’m using a pixhawk 1. Tried several boards and 2 different windows 10 laptops but all same result

Try a different usb cable maybe.

Still the same result…

Has the Mavlink2 been implemented ?
We suffer max 8 channels RC_OVERIDE function supported by this firmware.
I would be grateful if I could use MAVLINK 2 and can override more than 8 channels.
Best regards

@specyfick, yes, mavlink2 is available in all the vehicles. If SERIALx_PROTOCOL is set to “2” then that serial port will use mavlink2. Hope that helps

1 Like

I upgraded a Pixhawk clone 2.4.8 from Rover 3.4.2 to Rover 3.5.1. Everything is working well except the main led on the Pixhawk no longer works. It remains off during the boot cycle and follow-on operations. Any suggestions?