Servers by jDrones

Rover-3.5.0-rc2/-rc3 is available for beta testing

beta
beta-testing
beta-release

(rmackay9) #21

@David_Boulanger,

I suspect somehow the html file is being downloaded instead of the .apj file so it may help to download this .zip file that includes the fmuv3 version of Rover-3.5.0-rc2.


(David Boulanger) #22

Good job. Its loaded in and will bench test today and give it a work out on Wednesday. Thanks for everything.


(David Boulanger) #23

@rmackay9. Just bench tested and all looks O.K… The only difference is if put into auto with no waypoints Mission Planner says something like " failure to change flight mode" instead of going into hold. It stays in the last flight mode which in my case is steering. I have a 2 hour workout for it tomorrow. a little auto mission and a lot of loiter for video work. Anything you need checked out? I may do the waypoint mission with throttle and ackerman steering and the long loiter part with differential plus ackerman.


(rmackay9) #24

David,

Those tests sounds good, thanks very much for testing!!

The issue behind the “failure to change flight mode” is the new EKF failsafe which we added in response to some reports of “drive aways” (from @ktrussell I think) and I also saw it happen in our simulator.

If the EKF doesn’t have a good position estimate the vehicle will refuse to go into an autonomous mode. There’s essentially two “gates”:

  1. if the vehicle is disarmed, the vehicle can’t be armed in an autonomous mode. It is possible to arm in a manual mode.
  2. if the vehicle is already armed (in a manual mode) it won’t be possible to switch to an autonomous mode

As always though, the EKF failsafe can be turned off by setting the FS_EKF_ACTION parameter to zero.


(rmackay9) #25

@count74, @David_Boulanger,

We’ve gotten to the bottom of the build server issue which stopped -rc2 from going out for the “fmuv2” boards (which are older Pixhawks with a 1MB limit). I’ll be releasing -rc3 later today but it will be exactly like -rc2 but will have this one issue fixed.

Txs!


(David Boulanger) #26

All went good today. Ran a mission with throttle/ackerman, same mission with differential/ackerman, and then loitered for about an hour with differential/ackerman. Although differential/ackerman doesn’t really work well in reverse it loitered just fine with the stern into the wind. I have not looked at logs yet but if you need one for anything let me know.


(rmackay9) #27

David,

Great, thanks for the testing and feedback!


(rmackay9) #28

My feeling is that we can probably do the release fairly soon - perhaps as soon as next Monday or Tuesday. We’ve just gone through the Copter and Plane releases which resulted in tons of beta testing of the underlying libraries so I think things are quite stable.

… But I’m still very keen to hear about other testing people have done, thanks!


(David Boulanger) #29

@rmackay9

I can’t seem to graph anything. I don’t no if its mission planner or my settings/


(rmackay9) #30

@David_Boulanger, I think it’s the mission planner. In particular the “Use Time” option seems to have troubles.


(David Boulanger) #31

@rmackay9. I don’t know but this enough for today. here is a shot of the auto analyzer. Maybe I’m not logging properly or trying to log to much. I don’t know.


(rmackay9) #32

David,

The auto analysis looks OK… the analysis tool itself has some issues especially when used with rover (like FAIL messages for OpticalFlow which isn’t supported in Rover) but in general it looks OK. The mag fail is not that bad at 36% which is just over the “good” threshold of 30%. Txs!


(David Boulanger) #33

I’m graphing the logs now. I had to uncheck use time on mission planner. The mag field is usually ok or better but I had it close to me car when I booted up. Thanks