Rover-3.2.1-rc1 available for beta testing

Rover-3.2.1-rc1 is now available for beta testing through the Mission Planner’s (and perhaps other GCSs) beta firmware link.

This release is a relatively minor change from the official Rover-3.2.0 release including just one fix (ReleaseNotes):

  • Fix mode switch logic to allow Auto, Guided, RTL, SmartRTL, Steering, Acro using non-GPS navigation (i.e. wheel encoders, visual odometry)

So, for those who were trying non-GPS navigation (i.e. GPS disabled, using wheel encoders or visual odometry) but were seeing the dreaded, “Mode change Failed” message, this release could help. You will find that to arm in these autonomous modes you’ll need to uncheck the ARMING_CHECK parameter’s GPS box… or you can arm in Manual or Hold mode and then switch into the autonomous modes and it should work.

All beta testing people can do is greatly appreciated.

If no significant issues appear, we will make this the official release in about a week.

Thanks for your help!

OK. I am now able to go into auto mode with the POZYX system.

Wishlist. When using a beacon such as POZYX and other non GPS type navigation systems, it would be nice if the HUD said what type of “GPS” instead of “No GPS”. :frowning:

Thanks for getting this version out so quickly.


ps Now comes the next set set of problems like compass variance errors. All fun!

UPDATE: I tweaked the Arduino sketch… basically all x directions are now -y and y directions are -x. WHY? I have no clue … it was all a SWAG. but its works pretty good. Now comes steering smoothness… More Fun!

1 Like

Great news that the vehicle can get into Auto mode now, thanks for the report!

Hi @rmackay9,

Are you able rectify the ability for us to set turn_max_g setting to less than 0.2
I would like to set it to 0.02 but it does not seem to work. I think ardurover defaults to 10 as it sees the value as zero. Tried it with both Qground control and Mission planner.

I am still having a bit of issues with my tuning with ver 3.2.

Also, Can we also increase the Xtrack param from max of 0.2 to something a little bit more higher? An explanation of this parameter would be awesome

Thank you



Which screen are you using to set the parameters? I think I’ve mentioned it before but in any case, the MP’s Full Parameter Tree screen does not apply limits to the parameter values. Below is a screen shot in which I’ve set the turn-max-g parameter to 0.02.

If this screen isn’t visible, it’s because the layout needs to be set to “Advanced”.


I’ve seen that link previously but my experience of it has always been like this

See video below - Make sure setting is on HD otherwise it will be hard to see.

I can confirm that I can set the value of 0.02 via QgroundControl. QgroundControl won’t display the new settings correctly. It will show as 0.0

Turn max g set to 0.02 which is approx 0.2 m/s2 . Looks like I need to set it to 0.005

Do I have the right version of Mission planner? It has been recently updated to the latest beta
Any tips on Xtrack params?


Ok, so what you’re hitting is a bit of MP UI unfriendly-ness. After the message box, “Out of range, are you sure?” you need to press write again. I’ve created an issue for MichaelO here. For now, just remember to push the write button again.

I’ve confirmed in SITL that the TURN_MAX_G value does seem to be being used to limit the desired lateral acceleration.

The NAVL1_XTRACK_I parameter is an “I term” to ensure the cross track error (i.e. vehicle’s distance from the line between the origin and destination) reaches zero. I actually don’t think it should be necessary to adjust this. I think I-terms are generally not good to have in our higher controllers. The lower level turn-rate controller should be enough.

Ok thanks !

that is a huge tip! (click writ twice when params out of bounds)

worth putting in the wiki until it gets fixed

That solved it :slightly_smiling_face:

Back to tuning


I am now unable to use the auxiliary function switch.

My RC unit is a Spekrtum DX5e. The trainer switch is connected to channel 6. I can see the PWM values change in the MP Status window. I set the Aux_Set variable to 6 and the CH7_Option to 1. I am unable to set a waypoint.

When I change the ch7_option to 3, I am unable to arm/disarm.

Any suggestions?



Update 1) I was able to get save waypoints to work. I thought once you hit the waypoint trigger, it would show up on the screen. Silly me. But the ch7 opt to Learn Cruise Speed and Arm/Disarm still appear to be NOT working.


Any chance you could post a dataflash log? I can have a peek at it and see if I can spot the problem. I haven’t personally tested the learn-cruise-speed recently but I do use arm/disarm all the time so it can be made to work… still, i’m just one person so there could be something wrong of course.


Here are links to my latest logs. I hope what your looking for is in one of these. I looked but could not find the ch7 or aux variable.!AsZN_h-c802JiTHhHiYwYK4aEW3x!AsZN_h-c802JiU9xVVMWPzPQoAP4!AsZN_h-c802JiVX_aCcW_nr0UsUQ

Thanks for your help



OK, I think the issue is that the ARM_REQUIRED parameter is set to zero so the vehicle can’t be disarmed. Set it to “1” and I think it will work.


It seems every time I apply your suggestions, I realize how little I know about this very powerful system. Yep, all is much better now. In particular, I didn’t realize there was ARMING and DISARMING that is different from the Safety switch… and soooo important. I also didn’t realize I had to hold UP the aux switch during the SET CRUISE SPEED exercise. That now works fine too.

Thanks again


1 Like


Np, good stuff. The arming/disarming wiki page needs updating. It is one of the few wiki pages that I haven’t touched yet. It’s on my list though. txs again.