Servers by jDrones

Rover-3.2.0-rc3 released for beta testing

beta-testing
beta-release
rover-320-rc3

(Leonardo) #42

Nice!
Does that include ROS package?
I’m trying flytOS right now, but open to other options.
Thank!


(Leonardo) #43

My ESC is for brushless and it is centered at 1500uS. It has backward/forward capability.
I config OUT1 and OUT3 for 73 and 74 function.
Do I need to config the ESC as Normal or BrushedBipolar?

Thank!


(RoboBill) #44

@rmackay,

Another simple question… which file do I upload? Most of what appears to be log files are much larger than the 4500 KB maximum file upload size. Some of my log files are 300 to 600 meg.

Thanks

RoboBill

PS I am so far unable to analyse any of the log files. I get “Bad Input” or “Fail to load…”

PSS

Suggestion for next version… Since I’m using POZYX and not the regular GPS, please allow the MP to grab the current date and time from my PC for the dataflash log date/time.


(Leonardo) #45

How can I debug an ARMING problem and a Flight mode change faild?
I can’t go from manual to Auto.
Arming with CH1 seems to work one time (at first boot) and never more. I can ARM, but not DISARM…

EDIT: I can ARM/DISARM from MP
Sometimes I can engage Auto, CH1 and CH3 output remain in 1500.
EDIT2: I can change mode flight with the ASV DIASRMED. Once I ARME it I get “Flight mode change faild”

Thank


(derelicte) #46

@khancyr

I’ve had some success with getting a usb joystick to control the rover. I found that I need to plug in a rc rx and configure the radio. once that is done I no longer need the rx plugged in and the usb and virtual joysticks still work.

it would be really nice if the buttons were configurable for arming/disarming/mode/etc. like you can with ardusub. that would really be useful.

thanks for all your help!


(rmackay9) #47

Leonardo,

You should keep the ESC type as Normal.

The “Flight Mode Change” failed message is because the vehicle doesn’t have a good position estimate yet. If the vehicle isn’t moving in Auto then the EKF is not reporting a good speed estimate. I think we have a loophole during the startup period before the EKF is active where the vehicle has a good position estimate but not a good speed estimate. I’ve added an issue about it here: https://github.com/ArduPilot/ardupilot/issues/7471.
The underlying issue though is that the EKF isn’t yet happy with the information it’s getting from the external position source (i.e. GPS or other). I can’t be sure what the issue is without a log really.

P.S. I’ve been off for a few days.


(rmackay9) #48

RoboBill,

You’ve probably seen the wiki but in any case, the info on downloading logs is here: http://ardupilot.org/rover/docs/common-downloading-and-analyzing-data-logs-in-mission-planner.html. I think it is only possible to download logs while the vehicle is disarmed so perhaps that’s the issue. The .bin files are the most useful.

Happy holidays!


(Leonardo) #49

Thank!
Ok, I see on message panel that error, “GPS position difer XX mts…” or something like that. I put the boat in the middle of my backyard and that solved this problem.
Now I have some doubt about ARMIN/DISARMING. I ARM the boat for the first time after a boot up with my RC. Then I want to DISARM with my RC but it does not work. In QGC I press PAUSE button, then I can DISARM with my RC. Do I need to be in HOLD mode to be able to DISARM ? Is it configurable?
In a few days I will try it in the water!!!
BTW: How can I log telemetry data on uSD card?


(RoboBill) #50

I’d love to ul my logs to help out. I believe I’ve followed the instructions you linked me to. Unfortunately, I still end up with files that are way too large… as shown here

If I try to analyse any of these files through the MP, I get this error.

I know I’ve done something wrong… :crazy_face:

Thanks

RoboBill

PS I just noticed that “Bad GPS Mode” appears right before the “Flight mode change failed” appears on the HUD.


(Leonardo) #51

Ok, I’ve tested pixhawk + rover-3.2.0-rc3 on my ASV in the water.
I’ve a two problems.
The first is Difference from AHRS and GPS measurement. I want to switch to AUTO mode and get this error. I have a lot of SV (18) and low HDOP. So I can’t remove this error, so I get out of water and reboot my board (Is there a way to reset AHRS calculation? it is too complicated to get my ASV out of water to reset). Then this problem was solved.
It is seen in this LOG file.


Can someone try to explain why is this error ocurr? I think that EKF is used to estimate position, so why is there a comparision between GPS and AHRS measurement?

Then I’ve try to get my ASV to describe a SQUARE in AUTO mode. It is a skid steer ASV. The problem is that it is overshooting too much trying to get desired heading. Unfortunately I’ve didn’t read Tuning steering rate wiki and try to get a better performance tuning navigation parameters. I think that I need to reduce ACRO_TURN_RATE from 180°/sec to something between 30/60°/sec (my ASV could make a 360 turn in 2 seconds). And lowered P gaing in Steering Rate, from 1 to something like 0.3/0.5.
This is the LOG file for this second test:

What do you think?


(Leonardo) #52

Ok, I’ve spend 4 hour today trying to tune steer and navigation PIDs.
There is a big problem with PIVOT_TURN_ANGLE. The firs problem is the high velocity that this mode use. I config that param to 100°, so when the diference between current heading and Desired Heading or Waypoint direct angle? is greater than 100°, the ASV stop and start to pivot. The problem is that it start oscillating becouse of the high pivot speed. I could’nt finde a param to get this speed lower. Other think I’ve noticed is that sometimes the pivot directions seems to be oposite that obvious direction. I mean, it turn in the direction of the greates angle diferences, i.e. to the direction of 265° instead of in the direction of 100°. I’ve try with 10°, 60° and it doesn’t work, it is too fast.
I’ve trying disable PIVOT_TURN_ANGLE, but the ASV takes a too large radious to get the turn.

So, I really need PIVOT TURN, but I need a parameter to lowered the PIVOT speed.

Is there a graphical explanation of control loops involved in steer control?
I found andocumented parameters: ATC_STR_ANG_P. In the wiki I found ATC_STR_RAT_P

I found some Magnetometere variance error too. I’m in open space, in the midle of a river with 18 SVS, I’ve calibrated my magnetometer, so why I get this error?

I attached some logs, if you need some explanation of it can comment it.


Thank


(rmackay9) #53

Leonardo,

The oscillation during the pivot should be mostly resolved in -rc4 which is on it’s way out for beta testing in the next couple of hours. Kelly Shrock also found this issue (video) and I reproduced it and added a fix. The fix is we need to support “Feed forward” which is included in -rc4. I’ve also updated the “Tuning Steering Rate” wiki page because now the ATC_STR_RAT_FF parameter is the most important to get right. Normally it should be a value between 0.1 and 0.2.


(rmackay9) #54

Leonardo,

There are at least three ways to arm/disarm:

  • using the transmitter
  • using the ground station’s arm/disarm button
  • setup the ch7 switch to the Arm/Disarm function

If using the transmitter to arm/disarm, the vehicle needs to be in Manual, Hold, Steering or Acro mode (i think).


(rmackay9) #55

RoboBill,
Ok, I think you’re probably trying to use the “AutoAnalysis” button on the MP’s DataFlash Logs tab. I’ve just tried that and it failed for me in a similar way. So that sounds like something for MichaelO to have a look at.

Normally I don’t use the Auto Analysis but instead use the “Review a Log” button instead so that I can graph the output and see what’s going on.

-rc4 by the way, has much improved STER and THR logging messages are easier to use. For example, in the STER message, it’s easier now to compare the Steering Turn Rate controller (the lowest level controller) by graphing “DesTurnRate” and “TurnRate”).

Below is a graph of how my AION R1 is performing during pivot turns. The red line shows the desired turn rate and we see massive spikes during pivot turns (this is because of the non-ideal way we handle pivot turns for now) and also more gentle turn requests as the vehicle drives between waypoints. The green line is the turn-rate the vehicle is actually achieving. So it looks like the vehicle’s turn-rate controller is working OK. Not great but it’s OK.


(Leonardo) #56

thank you very much for all of your and the team work!

I think boat is a litle different than rover becouse of the lower "friction"
It is good to know that you are improve pivot steer control. I really need it.
I’m on vacation and will return to activity in jun 14, so I could beta test rc4 on my ASV.

Thank again


(RoboBill) #57

I now believe I I finally learned how to use the cloud, so my log file should be accessible via this link
https://1drv.ms/u/s!AsZN_h-c802JiBuyO2c2wQrl0li0

Thanks again,

RoboBill


(Esa Attia) #58

Hi @khancyr,

Yes , I’m currently working on our website .As soon as I get that up and running I will post up some of my work

Thank you for your work

Cheers