Rover-3.2.0-rc3 released for beta testing

A new version of Rover is on it’s way out for beta testing. It should appear in a few hours in the Mission Planner (and other GCSs) using the “Beta Firmwares” link. Changes vs Rover-3.2.0-rc2 are in the release notes and copied below:

  1. SmartRTL mode (retraces path back to home)
  2. Acro mode (pilot controls speed and turn rate)
  3. Guided mode ROS integration fixes
  4. Steering mode allows pivot turns
  5. Auto mode pivots on sharp corners
  6. Aux switch allows arming/disarming and mode change
  7. PILOT_STEER_TYPE parameter allows controlling turn direction when backing up
  8. Mixer change to allow steering to use full motor range (removes need for MOT_SKID_FRIC)

I’m afraid that because of the last item, if you are using a skid-steering rover (i.e. moves like a tank or r2d2) that you will likely need to reduce the ATC_STR_RAT_P/I/D values in half. Also you’ll find that the MOT_SKID_FRIC parameter that we added in -rc2 is gone - you should find that it’s no longer required because the steering response is far greater than before.

We hope that we are quite close to the official release depending upon how testing of this release candidate goes. If there are absolutely no issues, we will release it in a week or two as the official version.

All feedback welcome, thanks for testing!


Going to test right now to the field!

1 Like

well, testing was unsuccessful, pretty sure due to lack of enough time and being unable to setup the parameters correctly, but we were unable to make it drive autonomously, it looked like not realising being a “tank type rover”.
will report back soon with progress


If you were able to drive it in MANUAL but it wouldn’t move at all in Steering, Auto, RTL, etc then the issue is most likely that the EKF hadn’t settled on a good position yet. At the moment, it’s not possible to see when the EKF has a good position estimate just from the LED colour. When the GPS gets a good 3D lock, the LEDs turn green but it can take some more time before the EKF is happy.

If you have telemetry, the message, “Set HOME to xx.xxxx, yyy.yyyy at” will be displayed on the HUD once the EKF is happy. The messages window can be found on the Mission Planner’s Flight Data screen on the bottom left.

yes, we were able to drive in manual, but not in any other mode, as you state.
The home location was recorded correctly, and the positioning system is blend with 2 gps and a here rtk base station.
will try to do some more tests today playing with the pids/throttle/cruisespeed/turningspeed, since yesterday we just had 30 mins to test…

I too am unable to switch to auto mode… getting “Flight mode change failed” error. Again this is with the POZYX guidance.

It should just be that the EKF doesn’t have a good position estimate. If you have a dataflash log file we can check fairly easily. There’s an ORGN message that appears in the dataflash log once it’s set it’s home position.

I think the issue may be that we need to get the Mission Planner enhanced so it can send the SET_GPS_GLOBAL_ORIGIN message to tell the EKF where the vehicle is initially. I’ll create an issue…

EDIT: here is the issue requesting the enhancement in mission planner:

Did some early test with version RC3 today. Early test seems to indicate the ROS integration fixes seems to be working in guided mode.

1 Like

Since I don’t speak “Git”, when will I know #1702 fix is available to try out? Do I just keep checking for MP beta updates and look for SET_GPS_GLOBAL_ORIGIN in the parameters list or ???



It seems the latest beta MP has the feature. I haven’t tested that it works yet though.

Yes, I found it on the MP. I’ll try it out at first light… (since my anchors are solar powered) :wink:


1 Like

did manual control mode for joysticks ever get added?


There are at least two ways it can be done and both should work.

There’s the mission planner joystick method that uses rc-overrides ( This has worked for years but I see this page is not included in the Rover wiki (it’s only listed in the Copter wiki) so I will add it.

The other method uses the MANUAL_CONTROL mavlink message which QGroundControl uses and this is also supported in the latest release.

I’ve tried using qgroundcontrol and it pops up a message saying rover doesn’t support it (and it doesn’t work). Do I need to enable anything else in the firmware to make it work? When I load ardusub on the pixhawk it just works.

thanks again!

You need qgroundcontrol beta or lastest dev release. I don’t know why it hasn’t be merge into the lastest release…

thank you! I’ll give that a shot tonight.

I noticed that with RC3 I’m getting these types of messages more often

[ERROR] [1513138167.705763444]: FCU: GPS and AHRS differ by 11.0m
[ WARN] [1513138167.707062493]: FCU: Flight mode change failed
[ERROR] [1513138173.865756821]: FCU: GPS and AHRS differ by 10.9m
[ WARN] [1513138173.866832539]: FCU: Flight mode change failed

The only way to get rid of it was to restart ardurover application on my RPi.

Never had a “Flight mode change error” when running previous versions

OK after solving a number of unrelated robot/POZYX gremlins, I set the EKF Origin and gave it a try. Curses…I still get the “Flight mode change failed” error.

Other than that, manual control has smoothed out nicely compared to V2 :clap:

1 Like