Rotors speed are low

Hello everyone,
I just want to fly for the first time. I calibrated ESC but when I arm the quadrotor and move the throttle to max the rotors speed are very low so that the quad cannot take off. While if I want to change the yaw, pitch and roll the rotors speed increase. Can anyone please help me with this issue?

Did you calibrated your radio ?
How much motors Kv and cells of batteries 3S, 4S, 6S ?

Yes the radio is calibrated. The battery is 3S. I’ve never checked motors KV. Can you give me the proper range? Thanks.

Go into parameters and check THR_MAX. You will probably find that it was set to 80 (8%). Set it to 1000. I had this same problem the first time that I setup my Pixhawk because I selected the wrong setup to load initially.

I’m having the same issue with the same ESC’s and motors I’ve used on my APM countless times before, but I’ve been flying planes for a while and just move to 3.2. I’ll look into THR_MAX and see if that’s the problem.

Im not worthy…

Although I’m runnin APM 2.6-AC 3.1.5, this solved the last frustration with my power system. Cant understand why this setting has been defaulted to 8%… Brilliant.


My issued ended up being an issue with the PPM signal with a Futaba 8gf, and not the THR_MAX parameter.