Roslaunch:error loading <rosparam> tag

hi there, I tend to some ros-sitl but some error occurred
First I use Ubuntu 16.04, ros-kinetic-desktop (NOT full), gazebo 8, mavros
I cd to ArduCopter and use the line: -v ArduCopter --console --map "--sitl" "" "--out" "" "--out" ""
the MAP has shown,
and I followed the instruction on:, changed the fcu_url to default="udp://" and then opened a new terminal text:roslaunch apm.launch
but the terminal showed like this:
i have tried to uninstall ros and re-install but didn’t work. As I am new to ros, I have no idea what the problem is. If someone can help me, I will be very grateful


Could you share your apm.launch ?

	<!-- vim: set ft=xml noet : -->
	<!-- example launch script for ArduPilot based FCU's -->

	<arg name="fcu_url" default="udp://" />
	<arg name="gcs_url" default="" />
	<arg name="tgt_system" default="1" />
	<arg name="tgt_component" default="1" />
	<arg name="log_output" default="screen" />
	<arg name="fcu_protocol" default="v2.0" />
	<arg name="respawn_mavros" default="false" />

	<include file="$(find mavros)/launch/node.launch">
		<arg name="pluginlists_yaml" value="$(find mavros)/launch/apm_pluginlists.yaml" />
		<arg name="config_yaml" value="$(find mavros)/launch/apm_config.yaml" />

		<arg name="fcu_url" value="$(arg fcu_url)" />
		<arg name="gcs_url" value="$(arg gcs_url)" />
		<arg name="tgt_system" value="$(arg tgt_system)" />
		<arg name="tgt_component" value="$(arg tgt_component)" />
		<arg name="log_output" value="$(arg log_output)" />
		<arg name="fcu_protocol" value="$(arg fcu_protocol)" />
		<arg name="respawn_mavros" default="$(arg respawn_mavros)" />

ok … So it seems that mavros got something broken …
Did you try to update the package ? sudo apt update && sudo apt upgrade

Otherwise, you could make a copy of the apm_config.yaml to correct it.
Do :
roscp mavros apm_config.yaml apm_config.yaml
Then edit the apm_config.yaml you just create to remove
startup_px4_usb_quirk: false

Modify your local apm.launch to change
<arg name="config_yaml" value="$(find mavros)/launch/apm_config.yaml" />
<arg name="config_yaml" value="apm_config.yaml" />

Modify the apm_config.yaml in /opt/ros/kinetic/share/mavros/launch, and follow this PR :

It is just an extra space to remove. You will just need sudo for this modification.
I thought it was already updated.

@khancyr,I tried both methods and failed, but as @KiloNovemberDelta said, there was one extra space before setpoint_raw in apm_config.yaml
Now it works well:grinning:
RRRRReally appreciate your help

1 Like

ok, nice that you sort it out !