Servers by jDrones

ROS with ardupilot:Bad compass health

Hello i have been trying to build a rover with a raspberry pi 3 b+ and pixhawk.I followed the cartographer SLAM for non-GPS navigation.Everything is well except from the compass.I disabled all three but there is still a message in the Mission Planner HUD:Bad compass health.When i try to set some waypoints and test the cartographer,rover is lost and it cannot follow the desired direction.I tried disabling COMPASS_ENABLE=0 and then i get unhealthy AHRS in mission planner’s HUD.Any thoughts?

1 Like
Servers by jDrones