Rookie questions: Armeed/Disarmed & Flightmodes


I’ve spent the past few weeks working through the many online resources trying to figure out how to set up my Turnigy Trailblazer with 9X radio and APM2.5. While I’ve got most of the basics figured out, a couple of areas have me totally confused. I’d appreciate some guidance:

Armed/Disarmed: I see “Disarmed” on the Flight Data tab of MP1.2.53 when I connect. After a few seconds it changes to “Armed” and then disappears. What is the significance of all this?

Flight Modes: I’ve got my 6 position setup worked out with the correct PWMs as described on the Flight Modes section of Configuration in MP. When I set the flight mode to Auto (1550) the Current Mode changes to “Hold” while Guided (1685) returns “RTL”. Is this correct?


Hi Lukas,
If you do not have any waypoints programmed the APM may go into the Hold mode. If there is a loss of the receiver input the APM will go into the Hold mode.
The modes for the Rover should be, starting from the top, Auto, Auto, Learning, Learning, Manual, Manual.
I only use three modes: Manual, Learning, and Auto. I use the Flap switch on my Spektrum DX7 such that in the up position I have Manual, Learning in the middle postion, and Auto in the bottom position.
The HUD will display Disarmed until a 3D lock is obtained and there is R/C input. Then it will go to Armed and disappear.

Thanks TCIII.

Your response has enabled me to go a few steps closer to getting this thing working. Indeed, I think I have just one more hurdle before I can set off on an autonomous mission…

When I put the rover into Auto, the steering moves to aim towards the first waypoint but the throttle stays at zero. I’ve see posts referring to the need for altitude to be the same as the home altitude and also one which suggests that the APM needs to be greater than 10m from the Home location. I can understand the need for such measures with a plane but not a rover. I’ve also seen reference to the need for the vehicle/craft to be moving before Auto will take over. Well, I’ve changed the altitude, moved the rover away from Home and adjusted the Auto_Kickstart parameter, all to no avail. I cannot get the vehicle to move in Auto. What am I missing?

MP 1.2.53
ArduRover 2.41 AR2

Thanks in advance,