Roboclaw problem


I have a RoboClaw 2x60A Motor Controller wiring to a Pixhaw to control two trolling motors.
I only have got to work ok with analog signal setup on BasicMicro Motion Studio and also I need to deselect the mixing option. I thought it must be setup as RC signal but it doesn’t work at all.
On the other hand, I have a couple of extrange things…I must to set the MOT_SAFE_DISARM = 0 (0:PWM enabled while disarmed 1:PWM disabled while disarmed) because if I set to “1” the motors run at high speed when disarm the system…
The motors Works ok (tank style) but I need to select PILOT_STEER_TYPE = 0 (0:Default 1:Two Paddles Input 2:Direction reversed when backing up 3:Direction unchanged when backing up) instead of “1” as seems the correct option.
Further, when I switch off and on it seems like the Roboclaw loss the saved setup or something like that because I need to connect (usb connection to PC) and select/deselect the mixing parameter and it Works fine again…I don’t understant what happend…
I have Rover 4.0.0 and the motors are wiring to servo1 and 3 with 73 and 74 servox_function
The idea is to control a boat in Skid Steering mode. the motors are used to turn the boat, aditionally I have a big motor managed by a 3 phases speed frecuency regulator connect to servo2 output setup as 70 (Throttlle) by a PWM converter and it Works fine when I control the system with the Logiteck joystic. No test in auto mode yet.

Any ideas??
params_08062020.param (16.8 KB)

Anybody can help me?

The main question here is Why Roboclaw doens’t work if I select RC control, that means the motor doesn’t move at all. If I select Analog control, I can control them via telemetry by Pixhawk otuput as I explained above, but it seems the logic option must be “RC control” because the Pixhawk can’t take out analog signal…so I am afraid the “extrange” problems I have are due to selecting “Analog Control”, even if the motors seem to work

Anybody could help me?

Please somebody know what is the correct parametrization to get control the Roboclaw driver by Pixhawk? I tried to do the setup but only Works in Analog control mode, whatt is a Little bit confused to me because I thought the Pixhawk servo outoputs are RC style


I am sure, if anybody had any valuable input to help you solve your problem, they would have posted an answer. I never used a Roboclaw, only Sabertooth, so I can not really help, only guess.
PWM is used as a “digital” representation of an analog voltage. Normally analog voltage control would mean input from a potentiometer for example, but it may be that the Roboclaw reads the RC PWM signal as an analog voltage in analog control mode.
Is there a way to connect the Roboclaw to your PC per USB and to the Pixhawk at the same time, so you can see the input signals in realtime?
Most ESCs feature an arming safety, so if the PWM input signal does not match the neutral signal the ESC is configured for during power up, it will not output anything to the motors. Perhaps the Roboclaw does this in RC mode, too, but not in analog mode.
As I said, just guessing.

I am the same I have not used the Roboclaw either. I have had a quick look over the documentation and setup seems fairly simple. Have you followed the RC setup in the manual ?

On the Arming setting with motors I have seen this on other controllers as well so I’d not be concerned about that. They don’t quite work the same as an ESC and when the output is removed with disarm it can run the motors.

As for saving the settings I would reach out to them and see what they say.

I’ve noticed the same problem. I have a roboclaw 2x7A and it works on Rover 3.5.1 but not on Rover 4.0. I don’t have a scope, but the multimeter reading on the Servo pins is ~0.2 V on Rover 3.5.1 (which is similar to the output of the RC receiver), but on Rover 4.0 it reads ~1.5V. It’s almost like it is sending a PWM voltage? Is there another settings we need to change or is this a possible bug in 4.0?