Servers by jDrones

RNGFND_PIN - unable to select Pin 14 (Pixhawk ADC 3.3V) for Sonar

Hello!

I’m using a Matbotix Analog Sonar that I connected to my Pixhawk’s ADC3.3V port as described in http://ardupilot.org/copter/docs/common-rangefinder-maxbotix-analog.html

The analog Sonar signal is connected to pin 14 (as per http://ardupilot.org/copter/docs/common-pixhawk-overview.html). My problem is that I can’t select that input pin (14) to the RNGFND_PIN (Rangefinder pin) parameter in Mission Planner. The dropdown list allows: 0-9 (APM2) 11 (PX4), 15 (ADC6.6v port) or 64 (APM1).

I recall that in some previous version of Mission Planer this parameter didn’t have the dropdown list and I was able to manually input the number “14”. Is there a reason why this was restricted?

Thanks,

Dar.

BTW, pin 13 (which is also available in the Pixhawk ADC3.3v port) is also missing from the selectable values in the RNGFND_PIN dropdown list.

You can always insert any value you want in the Full Parameter list as shown in your first link - we should fix the documentation though.

Thanks Francisco. I hadn’t seen the Full Parameters List in Mission Planner for a while and assumed it had been removed. Clearly my mistake. Following your message, I looked for it again and found the way to access it by setting Mission Planner Layout to “Advanced”. I can now manually configure the RNGFND_PIN to 14 as I had done in the past. Thanks!.

Is there any reason why pins 13 and 14 are not selectable options in the dropdown menu for RNGFND_PIN?

Looking at it, I would say it was copied from another place and wasn’t adapted properly. Do you want to open an issue in our GitHub?

Yes. Will do. Thanks for looking into this.

1 Like

Hi, having the same problem now.
Still not implemented in 3.5
:wink:

hi everyone,
which pin (RNGFND_PIN) is the adc pin for pixhawk 2.1 cube black ? @darcopter @OXINARF

Servers by jDrones