Rngfnd issues sending depths to ardupilot 4.2.1

Hi team,

I’m have a problem I haven’t had before and hoping someone can tell me what’s going on,

On the boat I send back depth data to the data page in ardupilot 4.2.1

So I can see the depths while the boat is running.

I use the nema stream data from the transducer to a rs232 to ttl converter. The wiring goes to the Telem2 port on the orange cube.

Serial2 to 9
rangefinder to 25 orient an
(Depths cm)13min 10000max
And range finder 1 to 17 nema.

In the past models this worked fine.

But now I’m trying to create a new system and there are no depths on sonar range or range finder and seem to have 6 rngfnd categories. Before I only had one.

Is there a upgrade in the 4.2.1 that you need to “turn on” the data to send to the computer?

Please assist as this issue is causing some serious issues which I just can’t work out

Hi @Judd_McCann,

The only thing that looked suspicious in the pics of the parameters is the SERIAL2_OPTIONS parameter being set to 7 which means these three options have been checked:

  • InvertRX
  • InvertTX
  • HalfDuplex

Maybe do a parameter comparison between the working and non-working boat?

Common causes of serial protocols not being consumed is the SERIALx_BAUD rate doesn’t match the sensor, the TX and RX pins are reversed.

Thank you for getting back to me,

I have compared the param files between a know working system and the new system.

would you suggest for serial2_options set to 0?
Baud rates checked at 115.

I have checked it both ways, I have added and removed

The only difference I can see between new and old is setting 9 was LiDAR now it’s rangefinder.

Is there some way of proving what comes through the telem2 port. Eg to make sure that the data is actually coming into the port. I’ve replaced the ttl converter twice and it works fine… or do I need to turn on a pin?

Is there a different system to compare the param files, as there are differences in the the two files

Can you aid me with this, or teach me I am sure there is a simple fault but for the love of country or money, nothing works and I can’t what is wrong. It’s been 63 hours on this problem in the last two weeks and I’m blind to what’s happening

I also get two new errors to me when arming

Pin 54 Servo13 set to -1
Rangefinder no data


Could you provide the two parameter files from the working and non-working vehicles?

Another alternative would be to provide two onboard logs (one from the working vehicle, one from the non-working vehicle) but this might require setting LOG_DISARMED = 1 for the non-working vehicle because if it can’t be armed then it won’t produce a log unless this parameter is set.

BTW, that error message is because the RNGFND1_PIN parameter is set. This should be set to zero because the rangefinder is not using an analog pin to read the depth, instead it is using NMEA (or should be).


Mate, your a legend! Thank you

Attached are the two files, named for ease as “working” downloaded off a system built in 2021 and “not working” off the system built in august this year.

Ill change that rngfnd1 to 0, I have rebuilt the hardware again but no dice, the problem is consistent

working.param (16.4 KB)

notworking.param (17.7 KB)

Thanks for the param files. Could you try setting these, reboot the autopilot and try again?

  • EK2_ENABLE = 0 (was 1, but EKF3 is enabled, don’t need both EKFs)
  • RNGFND2_TYPE = 0 (was 17)
  • RNGFND3_TYPE = 0 (was 17)
  • RNGFND4_TYPE = 0 (was 17)
  • RNGFNDA_TYPE = 0 (was 17)
  • SERIAL2_OPTIONS = 0 (was 7)

Thank you thank you thank you

It’s mmworks! It was the multiple rngfnd types not set to 0

Thank you again

1 Like