RGB Status LED turns off in boot sequence

I am running Ardurover 3.5.0 on Raspberry Pi, Navio2 hardware. Current testing is indoors with no GPS signal.
The status RGB LED on the Navio2 board comes on when first booting (not a hardware problem), then shuts off about the time that the Sik radio starts up (via USB). I can arm and run the motors via the transmitter.
Is there a parameter I am missing to turn on the RGB LED? The LED was working when I ran Arduplane.

Hi, thanks for the report.

I worry this will be hard to figure out because we don’t have a lot of Navio2 users. If Plane works then Copter should as well because they share a lot of code including the AP_Notify library which is responsible for the LED.

Perhaps try removing all peripherals (i.e. the Sik radio) to reduce the chance that it is a power problem (some flight controllers or USB cables can’t provide enough power for both a flight controller and a radio) and revert all parameters to their defaults (maybe take a backup of the params before doing this). The purpose of this is just to get the vehicle back to a known default state… then check if the LED works.

Next I wonder what versions of Copter and Plane are being tested.

… then maybe a dataflash log although I suspect it won’t highlight the problem.

I have an archive of the parameters, so will give it a try in a few days.

The good side, the differential thrust is working nicely.

Now just need some decent weather to get the boat on the water.

1 Like

I have been working on troubleshooting a similar problem. Try disconnecting the GPS and see if it starts to function.

I was back in the lab and ran a few tests. Since this is a Navio2, the GPS is built into the board and cannot be disconnected (@mike), but this seemed to have no impact.

  1. Swapped out the SD with an old Arduplane 3.8.5 and it worked fine (LED remained on)
  2. Swapped out the SD with Rover 3.3.0 (Navio2 image). When power was applied, the LED came on green, then went out when the boot sequence started, then came back on and worked fine. It came back on about the time the Sik radio started chattering.
  3. Swapped the SD for Rover 3.5.0 (custom binary upgrade). When power was applied the LED was green, then turned off when the boot sequence started, and never came on again.
  4. Reset the parameters to default and rebooted. Same result as #3. I even removed the ‘brain’ from the rover (boat) and plugged it into a monitor to watch the boot process - everything was OK with no errors.
    Hope this is of some help. Let me know if there is anything further I could try that might help shed some light on the issue.

I assume rover 3.5 has much of the 3.6 in master and I am chasing a similar problem on an entirely different platform with3.6 copter. During boot most of the way through my OLED display gets updated that the GPS is found and about then my indicator lights turn off. It has something to do with serial devices that are plugged in at the time but I am still working on it.