RFD900x stuck at "Getting Params" after trying to connect in the MissionPlanner

Issue details

Hi Guys, I have flashed and tried with latest ardupilot firmware of plane and copter in Cube Orange+, I have connected one RFD900x with Cube with TELEMETRY 1 Port, and given 5V power supply from external source, another RFD900x is connected to the PC with FTDI. RFD900x is also flashed with latest firmware(3.57) and hardware is V2.0 .
I have checked all the TX,RX Cables everything is connected fine.

When I open MissionPlanner and go to Optional Hardware → SiK Radio and then I click on the load settings I am able to see all the parameters of the remote and local RFD900x device as shown in the below image.

After this when I try to connect COM6, with the baud rate 115200. I get connected but then while getting the parameters Mission Planner is stuck at getting params for hours as shown below, although I am able to see HUD Parameters changing like, altitude, yaw, vertical speed, etc.

Things that I tried

I have tried these multiple things for the resolution of these issue but no luck :

Changed baud rate to 115200 and air speed to 200.
Changed baud rate to 57600and air speed to 64.
Changed baud rate to 9600 and air speed to 64.

I was also changing parameters like SERIAL1_BAUD to 115, 57 and 9, SERIAL1_PROTOCOL is 2 (MAVLink2), SERIAL1_OPTIONS is set to 0.
BRD_SER1_RTSCTS tried at 0.

TX Power tried 5,27 and 30.

I tried changing Mavlink to standard and low latency both.
I tried changing MAX WINDOW to 131,80 and 20.
RTSCTS and ECC is untick.

I also tried interchanging both the RFD900x but still no luck.


Arduplane 4.3.2 and also latest version of Arducopter firmware.

Airframe type

QuadCopter and Quadplane.

Hardware type

Cube Orange+

Please provide your possible resolution for this, Thanks.

1 Like

Are you sure the number of channels is correct? I’ve not seen 50 before. Mine ends up about 20 or 21 and I think it might be dynamic, the number of channels depends on some of your other settings.
But try 20 if you have to, you can always put it back later.

Unselect the OpResend too.
particularly for live telemetry in flight, you dont want to be wasting bandwidth trying to resend any missed data that is now out of date, superseded by newer data.

You need

and on the RFD’s
Baud 115
Air speed 200 (this must always be higher than baud)
Max Window 80

I use a lower TX power, you dont need to change that unless you want to. It could help when the radios are close together, and you’ll still have more range than visual line of sight. This also makes it safer to power the radio from the flight controller serial port provided the serial port is rated for that. (Cube serial 1 is OK for that)
RFD900 updated settings

Hi Shawn, I have tried these, but still no luck.

you can have up to 51 # of channels, I am not terribly sure about it being dynamic or not I have always set mine to 51. As long as both airside and ground match you will be fine. I tend to not use the mission planner sik radio config page and tend to stick with RFD’s modem tools Modem Tools | RFDesign Files. You could also try resetting these radios to default to see if that helps but they are fine as they connect to each other so this has to be a setting within arduplane. Below are my master settings for my all my rfd900x(ux) radios.

Hi @406FPV & @xfacta, can you please look at my setting parameters of ardupilot in the original post and can recommand if any other changes needs to be made, and if you can please provide how your telemetry cable’s pin are connected from cube to RFD900x.

I had to tweak the cable, because i had the cable of pixhawk 2.1, I am giving power supply of 5v from external source and haven’t connected RTC & CTS cable.

Just TX → RX and RX → TX (a cross-over cable)
Use BRD_SER1_RTSCTS,0 to ensure CTS/RTS is disabled for that serial port.
If you do use CTS and RTS they are “straight through” and not crossed. You can actually hook them up, but ignore them via the config.
Ensure the GND wire is common the the flight controller, the radio and the BEC

1 Like

Hi @abhisheeekkk, I am having the same issue, did you figure it out eventualy?

1 Like