Servers by jDrones

RFD900x SBUS / PPM support added

Hi Everyone,

Thought to give an update on the RFD900x series modems, that we have added SBUS support from version 3.09 onwards. It also supports translation to/from PPM on both the ground and in the air side modem, so should make configuration options quite flexible!

Keen to hear feedback on the experiences with how it works for you.

Cheers,
Seppo @RFDesign

5 Likes

Hello Seppo,
Could you send me some instruction please?
rfd

Hi Seppo @RFDesign
This update v3.09 is in beta.
Is it safe to use the beta version for a ready to fly vehicle (OR just for beta testing purpose)

For the ground based modems, either RCIN or SBUSIN should be checked.
For air based modems wither RCOUT or SBUSOUT should be checked.
They can be mixed between RC(ppm), or SBUS in the air and ground, the modem will translate both ways.

RFD900x-3.09 has been released for a while we have not had any issues to date, PPM is very stable, has been in use for almost a year, but, it would be good to have feedback for SBUS, that has been in use for 2-3 months.

I have tested this in my RTF Hexacopter without any issues.
Have done number of flights until now.

@Seppo
I am unable to use either the gui or command line to set sbus in or out using rfdtools 2.33. Both modems are running 3.09. Is there a new version of rfdtools I should be using?

Hi Matt,

If there are any conflicting ppm/sbus settings, that could be precluding the parameters from being set.
Would you be able to do a factory reset, (Restore defaults button), or AT&F, AT&W, ATZ on the modems and try to re-set the PPM/SBUS settings?

If there are still issues, would you be able to downgrade the firmware to an older version, V2.53-4 or so and re-upgrade to 3.09. This will also force a parameter table reset internally.

Seppo

Hi Seppo,

I too am having the same experience as Matt; I tried both a firmware downgrade to V2.53 and restoring defaults but am still unable to get SBUS passthrough working.

I am sending 16 channel SBUS from an FrSky X8R receiver to the RFD900x.

For clarity, should I be using Pin #15 or Pin #12 for the SBUS in and out?

Thanks
Jason

@jasclarke308,
both s.bus/ppm will be on pin 15. For your ground side it needs to be set to sbusin for the radio to receive the sbus signal, on the ground side you can select sbusout or rcout as the signal is mixed on that end and will be sent accordingly. @Seppo I have still not been able to set any of the sbus setting either in the GUI or in command line. I have downgraded to 2.55 then back to 3.09, restored defaults after upgrade still cannot get any of the sbus settings to stick and in the GUI the options for sbus are simply grayed out running modem tools 2.33.

Alrighty folks! I have sat down and managed to get this to work. You will be unable to use the GUI to set sbus at least I could not get it to work and will have to use the terminal access on RFD tools 2.33. On the radio for the ground side you need to set this command ATS18=X (where x is the protocol for sbus these are the options to use
0. SBUS output disabled

  1. SBUS1
  2. SBUS2 - 12CH
  3. SBUS2 - 18CH
  4. SBUS2/1
    I am using an X8R and choose option 4. After setting ATS18=4 hit enter, you then need to do the AT&W command to write the change to the radio. After you have done this you can do ATI5 command to see if the sbus setting stuck. Next program the airside.

On the air side you need to enter this command ATS19=X (where x is the protocol for sbus these are the options to use
0. SBUS output disabled

  1. SBUS1
  2. SBUS2 - 12CH
  3. SBUS2 - 18CH
  4. SBUS2/1
    I again choose to use 4, After setting ATS19=4 hit enter, you then need to do the AT&W command to write the change to the radio. After you have done this you can do ATI5 command to see if the sbus setting stuck.From reading what @Seppo said earlier you can either choose to turn on sbus or rcout on the air side and that should get you working as it will figure out what to passthrough, but I decided to just enable the sbusout and made it option 4.

Here is the link to the latest and greatest docs for these radios!!! big thanks to @Seppo and RFD team for getting this working, as the limit of 8 channels on the ppm passthrough was kind of limiting for some applications!

1 Like

Hi @Matt_C, those directions work perfectly, thanks.

@Seppo, would it be possible to add a feature for SBUS failsafe options? At the moment it seems like the default is to output ~820us on all 16 SBUS channels in the event of loss of radio link, but for our application it would be much better to simply not send any pulses at all. Would it be possible to add that option to a future release?

Regards,
Jason

Servers by jDrones