RFD900x PPM Failsafe recording fails

I’m having issues getting a set of 900xs to record a PPM Failsafe. The PPM passthrough is configured appropriately and working well. However, when a radio connection is lost the Failsafe values go to 1000 across the board.

When I connect RFD Tools to the ground side radio I get no response when I press the “Set PPM Failsafe” button. When I connect to the air side radio (with the ground side radio powered on) I get the following messages: “Sending AT Command” then “Fail”. In both instances I have my RC receiver connected to the PPM input on the ground side radio and my RC Transmitter on and outputting my desired failsafe values.

I’m using the latest Firmware and Latest version of RFD Tools.

1 Like

Yes, with Seppo’s help we determined that it was a bug with the user interface in the RFD900 Tools software.

You can program the failsafe successfully by using the CLI/AT Commands using the terminal built into RFD900 tools. The proper sequence of commands for recording the failsafe is as follows:

+++
AT&R
AT&W
ATO

Be sure to test the failsafe settings by powering down the ground side radio and ensuring that the RC inputs read by ardupilot are correct over USB.

1 Like

We are currently shipping v2.65. I’m excited to test the S.BUS compatible firmware when it is released.