Servers by jDrones

RFD900x mouse movement issue

(Tuna Lobster) #1

The issue is the mouse starts hopping around the screen when the RFD900x is plugged in.

This happens when the RFD900x is powered from an external BEC set to 5.5V or powered from the USB port. 3 different laptop models have shown the issue. Toughbook CF-53, Latitude E5540, and an Ideapad Y50-70. The Ideapad has been the least affected by the issue but it still happens on a semi-regular basis. Several RFD900x radios shown the same issue. Board version of the RFD900x does not seem to matter. Several USB to pin breakout FTDI cables were tried as well. Stock antennas and 3rd party antennas were tried as well. Firmware version is 3.07.

I am close to ground isolating the radio and FTDI cable in hopes that isolation fixes the issue.

2 Likes
(Andras Schaffer) #2

Disable serial mouser driver in Windows. Sometimes a mavlink connection data is misinterpreted as serial mouse and a driver is activated.

  • Navigate to the registry key named: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\sermouse
  • On the right hand side of the registry editor window you should find subkey named: start
  • Double click on the “start” subkey and modify the value of the key to: 4 and click the OK button to return to the registry editor window
    Note: setting the “start” subkey value to 4 will disable windows from looking for serial mice at startup

Reboot…

1 Like
(Tuna Lobster) #3

Thank you! It’s working much better now!

More information about the sermouse Start key values here.