Rfd900x modems connect but no communication

Just got rfd900x modem and txmod jr bay module .
They both show solid green but no rc commands going out and no telemetry coming back .
This (air side) is connected to matek h743 wing fc .
Taranis x9d+ is set for ppm on external module . Nothing .
However What I can do is take two rfd900x modems ,one on laptop thru ftdi and the other connected to h743 using SERIAL1 set for mavlink2 . These two will connect and I can even connect to MP and see telemetry coming back from fc .
I’ve used crossfire tx and nano rx in past set up the same way and its aways worked , even now I went back and put crossfire setup back together and it still works .
So the issue is the txMOD v2 and the taranis .
Reams of documents from rfdesigns are of no help .
I can connect to txmod when its the remote and I’ve got rfd900x modem on laptop .The other way is thru txmods wifi but app asks questions like host name/ip and port number . I don’t know what these are . I can connect thru their app (looks just like sik radio app in MP) and make sure all settings on txmod are correct .
Just can’t get any connection between txMOD and taranis .
I know this is not ardupilot directly but so far rfdesigns tech support have not offered anything yet .
Any input much appreciated .

Just to confirm, did you setup the txmod via the txmod web interface? And with this did you set both radios net id’s to the same? (standard is 25)

And with the X9D, did you set it to ppm channels 1-16?

Also dont change the ms settings in the x9d.

Also try giving RFDesign a call again, i will wait for the phone to ring :slight_smile:


I cannot get at TxMOD web page because I don’t know what to enter when I try . It asks for “host/ip” then a “port” .
I don’t know what to enter and the half dozen or so things I’ve tried have not worked .
I do know TxMOD is functioning since I have solid green at both ends .
As far as your suggestion I have only managed to get at TxMOD by using it for the remote and connect via a RFD900x modem I have connected to pc by com port .
I have no trouble at all with com ports but the TxMOD doesn’t have any usb connectors . The only way in is either WiFi or through another modem .
Yes I have set net Id to the same value and saved it while connected thru another modem .

Second reply . Yes I have x9d + set to ch 1-16 .
I don’t know what you mean by “ms” . If you mean “milliseconds”
And are referring to the ppm frame width that appears after channels
I have not touched it .

Third reply
I think I interpreted your response wrong .
Yes I’ve read the TXMOD user documents .
Yes I have gotten to the “configuration webpage” and successfully run the “first run wizard” .
That’s as far as I got .
The result was a non functional radio , no RC commands going out and no telemetry coming back .
When I say I can’t get to TxMOD WiFi module I mean getting there thru
The rfd tools app (looks exactly like sik radio page in MP).
That’s where I get all these host/ip and port questions