RFD900X issue entering command mode

Hi, I have a RFD900X, I’m trying to change the NetID but when connected to the laptop and using the latest version of RFD900 Tool 2.10 it keeps saying “Failed to enter command mode”. I’ve tried every baud rate and the com port is correct. The green light on the RFD 900 is blinking slowly.
I’ve tried the other RFD900X module and it works fine and able to connect to the tool. I’ve also tried using Mission Planner and get the same error. What can I do to fix it? Thanks

Interesting.
I have encountered this with 3 RFD900+ that I installed the multi-point onto and now I cannot configure them.
I am getting the same message ‘Failed to enter command mode’.
At present they’re just sitting on the shelf until I have time to work this out.

Anyone?

Mine is also still just sitting on the shelf…anyone? I’ve emailed RFDesign 2 times with no response.

1 Like

Did you guys, tried to reflash with point-to-point firmware ?
(forced boot mode if necessary)
" In case there is need to force the modem into boot mode, short circuit pads 1 and 2 (labelled
BOOT) on the 9 way test pads"

OK finally got it to work. I used the RFD Tool 2.10 and short trick.

Short pad 9 and pin 16 while powering up, i could get the red light to come and stay but it still didn’t work. The trick is to keep the pins shorted while you hit the upload firmware button on the RFD tool page. I used a pair of metal scissors to short them and when i held them in place and hit the upload button it worked.
After uploading the new firmware, RFDSiK V2.55, i could then plug it in normally and program the Net Ids.

Thanks for the help. I never got a response back from RF Designs…not happy at all with their customer service.

1 Like

The multipoint firmware is not supported by Modem Tools (as of Feb 2019). You have to configure it using a serial terminal and AT commands.

1 Like

@Scott_White, is there any user manual explaining how to use the serial terminal to upgrade de firmware?

I just used the modem tools to load the firmware: http://files.rfdesign.com.au/tools/

I also found this project, but did not try it.

Hello

i have RFD868x modems which where worked perfectly. Then I just out of curiosity changed Baud: 1300 and Air: 700 (don’t remember exactly) on local and remoe. And since then doesnt work. I also forced both modules into bootloader mode with connecting pad 9 and GND pin and then applaying power to the modul. Modules seems switched into bootloader mode by turning LED light into solid red. Then i pushed connect (comXX, 57600), hit Upload Firmware but still gives me notification “Couldn’t communicate with modem. Try power-cycling modem.” I really dont know what to do…hope some can help me…? Maybe i bricked modules.

Hello, i have same problem,did you find a solution?

That is to say, when the RDF900 brushes the multi-point firmware, can’t their official tools be used? Must use an AT tool?

How many pins can be shorted to enter boot mode?

I am also having trouble connecting the RFD 900x-AU which I only purchased a week ago,
The lights just flash green but can’t connect, have tried every baud rate.
Also tried to send AT commands with various baud rates with no success.

I will give RF Design a call tomorrow and see what they think

Reagrds

Phil

Update:

I downloaded CoolTerm

I turned off flow control and software-supported flow control as well as set the Initial line states DTR and RTS to Off and attempted to connect to the 900x at 1200000

I entered +++ to console and received reply back OK (Putting into AT command mode)

From here I made sure the board had reasonable settings in it using ATI5 which returned


I then used ATS1=460 to set the baud then AT&W to write it then ATZ to reboot, at which point i also power cycled.
Opened RFD900 Tools and connected at 460800

Appears the only issue was that RFD900 tools does not have a baud setting above 460800, so after you set the baud rate higher on the 900x, you are unable to connect to it with RFD tools.

Hope this helps anyone who has run into the same problem.

Regards

Phil H.

1 Like

Hi Phillip,

I have the same problem, I installed CoolTerm and followed your instructions. When I type +++ I don’t get OK or ATI5 or anything at all. do you have an idea why?

Hi
Try different baud rates, if that fails, try to reset the board and then try again to connect.
the baud rate must be the last know baud rate you set it to, eg.
576000
921600
1200000
1500000

Other options are to try a different serial to USB converter that is compatible with the board.

Regards

Phil

I often use Termite instead of CoolTerm and make sure to have no Carriage Return (CR) or Line Feed (LF) enabled when issuing +++. Then after getting the OK response I again enable CR and can then query the radio using the AT commands. Maybe you can check in CoolTerm if CR and LF are disabled and give it another try.

Hi Phil,
Thank you for your reply. I tried to remember the last baud I set but I couldn’t. The best way would be to reset the modem. Do you possibly know how to reset or force boot the modem? I have a 900x. It says short circuit pins 9 and 16 but I don’t know how to do it?