RFD868+ connection problem Mission Planner

Hi, we are using two RFD868+ modems to replace the 433MHz 3DR modules for getting longer range.
The firmware on both is RFDSik V1.91 rfd900p.ihx
Mission Planner Vers. build 1.3.7672.14476
Connection on pc is done with TTL 232 cable and short cut pin, on UAV with external BEC and Cube black Telem 1 with Copter 4.05 firmware.

Cable connection is:
Pin5 on RTS 11
Pin4 on CTS 03
Pin3 on TX 09
Pin2 on RX 07
We do get solid green lights on both units, also the red are flashing,
When connecting the mission planner, everything looks normal,
SIK radio remote RSSI is shown with 222, Sik Radio RSSI 223, link quality GCS 16
then we are in a loop showing “Getting params…”
Switching back to the 3dr 433 MHz units shows that it works as normal…
Settings in RFD moduls is “standard mavlink”, power reduced to 10 on the pc unit as I use USB 5V, which is limited,
Every help is welcome, as I did spend several days now with it and I run out of ideas;-)

to add… meanwhile I did a new cableand also tried telem port 2, stil the same…solid green, but no end of “Getting params” so its not the cable.

noone? Would it be better to publish in mission planner?

I am using RFD868,+ but with the latest firmware which is RFD Sik 3.20 on RFD868x, works good for me. Connected as described here.

Don’t forget to change the settings of SERIAL port in Mission planner like SERIAL[X]_BAUD=57 SERIAL[X]_PROTOCOL = 2 (or 1 if you use Mavlink1)

Configuration as on the picture.

Hi Artsiom and thank you very much for the detailed answer.
As i have read RFD 868+ and RFD 868x are not compatible. For RFD868+ we do need a firmware ending with “.ihx”, for RFD868x with “.bin”. Therefore I cant use the Sik 3.20 version.
This are the different version 1.13,1.12, 1.9 and 1.91 I had tested, all with the same result…green constant LED, but loop in “getting params”

Ok, got it, just a assumption, might be make sense to play with air speed.

Okay, with the help of the support I was able to solve the mystery. So I added a cable from the air unit ground to the pixhawk ground as the GND had to be connected. After this the connection worked, but reaaaalllyyyyy slow…
Next was activating RTS CTS in the module settings …no change…I changed the flow setting for pixhawk from auto to RTS CTS and now it works like a charm…only thing is it takes the countdown of mission manager connection timer down to 10 til it starts. The 433Mhz modules of 3dr and its clones start immediately.
Nevertheless solved for me. Artsiom, thanks for the effort!
---- closed —