RFD very very slow at loading prams 30min+

I am using RFD868+ (baud rate 57600, air speed 64, 50 channel hop, duty cycle 100, ECC checked, Mavlink checked, two antennas on each end, do not have RTS/CTS checked, running SIK 1.12 on both), AMP 2.6 with Missions Planner. When I hit connect the connection takes less than a min but it takes over 30min for the “Getting Prams” to complete.
In the past I have been using 3DR radios and the “Getting Prams” took less than a min.
I am bench testing so I have the power setting at 10 with 15metres and two concrete walls between. I have tried higher settings but it’s the same.
Any one know why it is taking so long to Down load the prams? Fairly Frustrating!
Thanks in advance,

I have tried higher and lower tx settings and pretty much the same. I have also tried the RTSCTS setting and if I use it connection fails.

I’ve had very little experience with RFD radios so far but I suggest trying their radio modem tools.

The file contains an executable for a little GUI that can connect with an RFD radio, upload new firmware and read/write settings. I’ve found the connection can be wildly inconsistent especially when uploading firmware but never slow (it either works or returns a byte read error within a minute or so).

At least give the tools a go and you can see if the problem is more likely to be caused by Mission Planner or your modems.