RFD 900 Radio Calibration Failure

I am working on a bathymetric boat project that uses a Pixhawk black cube. I have updated all firmware, and have the latest version of Mission planner installed. I’m currently experiencing issues with the telemetry.

My current radio setup is as follows
One RFD 900 radio connected to the TELEM2 port of the pixhawk. Pins 1 and 6 of the TELEM2 port are connected to pins 2 and 4 of the RFD900. The remaining pins were wired according to this link (https://mozzie.readthedocs.io/en/latest/RFD900xSetup.html) except for the RC IN port, for I could not figure out which RFD900 pins needed to connect to RC IN.

I am powering it off of the same port (although I have come across other forums that advise against it. I will made those changes after I am able to figure out my telemetry issue).

My second RFD900 radio connects to my computer. This second radio has an FRSky d4r-ii attached to it to allow my Taranis X9D to communicate with mission planner.

I am able to pair my radios successfully. My FRSky is also successfully paired to my Taranis X9D.

The issue I am having is that when I open Mission Planner and go to Radio Calibration, I am not able to see any controls. Instead of the bars having green, they are just blank. I have attached a screenshot to show what I am seeing.

I don’t currently have anything connected to RC IN of my pixhawk. If I were to need to connect to this port, which pins on my RFD 900 would I be hooking up to?

Thank you in advance for any help with this issue!

First you need to use the RFD Tools RFDesign Files
to designate one radio as RC In (the ground unit) and one as RC Out (the air unit) if you havent already.
Select the GPI1_1R/CIN or GPO1_1R/COUT check boxes as appropriate.

Actually this now works in MissionPlanner too:

In both cases Pin15 is the RC/PPM pin to use for in or out respectively.

On your air unit, power it from a separate 5vdc supply, not from the flight controllers Telem port.
The RFD pin15 should be connected to your flight controllers RCin.

Once everything is configured, calibrated and working (before you fly) you NEED to set the failsafe state.
Set the radios channels exactly as you want them in a radio failsafe situation (loss of link), such as:

  • Throttle at hover value (mid stick)
  • flight mode switch or some other RC channel set to RTL
  • In the RFD Tools, or MissionPlanner Sik Radio screen press the Set PPM Fail Safe button for the air unit

The radio will remember that RC channel config and use that on link loss.

If you use a 3 position switch for flight modes, like Stabilise, AltHold, Loiter , then you can set another switch to be RTL (or Land, whatever you like)

  • In your radio assign a switch to a spare channel, say channel 8 in this case
  • In Arducopter set RC8_OPTION,4 for RTL (or 18 for Land)
  • Test it in the radio calibration screen

When I go to select the GPI1_R/CIN box, it doesn’t let me check the box. What do the setting have to be set to in order for me to have to option to set RC in?


@xfacta

OK that’s an old version of firmware. Use the RFD files link to download the latest version for your radio model. Use the RFD Tools to install it, although I think even MissionPlanner can do that too.
Unselect the OP Resend setting too.

If you are planning on mega-distances or operating in very noisy environments you can leave the standard baud rates. Otherwise you can try these settings and get USB-like data throughput, able to download logs and all…

image
Note that I had power turned down a bit, Tx Power = 27, you can leave yours up.
Your NetID is OK, so long as both radios are the same.
Dont try to change the frequencies or the Format.

EDIT: for the high baud rates the important settings are Baud, AirSpeed and MaxWindow.

@xfacta

I uninstalled/reinstalled the RFD 900 Tools app, and that did not change my issues.
I did the same for the Mission Planner app, and still was not able to select GPI1_R/CIN.

Could you provide links to where you are downloading this software? I am not sure why it’s still not working

Unfortunately you have the RFD900+ which does not support PPM/SBUS passthrough. Only the RFD900X does.

Thakfully I had some RFD 900x’s in the shop. I went ahead and swapped them out and was able to see select the GPI option.
I set up the settings as suggested earlier, but I am still not seeing anything change on the Radio Calibration setup page.

I connected the RFD 900x’s Pin 15 to the RC pin of the Pixhawk. I am providing power from a separate power source. My radios are pairs (solid green lights on both). My telemetry settings have been changed to the correct value. I am not sure what is left for me to do at this point? Am I missing something?