RFD 868X bootloader

My two radios bind but I can not access them through either mission planner nor rfd Tool. They simply talk’s to each other but not to me.

I have tried different ports, computers and baud rates with no help and my last option is to force them into bootloader mode but how isthis done?

Here is the manual procedure:
“If the tools cannot establish boot mode try to manually force bootloader. This is done by
holding a short, on pad one and two on the +, a and u modems, or, pad nine and shield for x
series modems, as you apply power to the device”.

So I should go for oss 9 and shield, but what is the shield? Is it the ground pin?

Thank you.

I’ve found some videos in YouTube when you get stuck in bootloader but not how to activate bootloader.


This is all unusual, more likely a wiring issue.
Do you have TX → RX and RX → TX regarding Flight Controller → RFD ?
CTS and RTS are not crossed over like TX/RX. You really dont even need them connected at all depending on parameters.

What Ardupilot params do you have?

I use the same com port as shown in device manager for both MP and RFD Tool. Baud is 57600 and I am not able to connect them to either MP or RFD Tool. I have tried to change FTDI and swop TX/RX without succes.

So I got it to work again by shorten pad 9 to shield and forcing the modem into bootloader. Then I uploaded the latest firmware RFD SiK but that did not help. I then tried the latest RFD SiK Complient firmware and this worked.

I’m now able to communicate with the modem through RFD Tool and MP but MP is still causing some trouble. I get the horizon, heading to work but it’s stuck in “Getting Params…”.
I reduced the output power to 10. Could this be the issue or is there something else i missed?

My misstake: i swopped CTS and RTS and now parameters loads in seconds.