Servers by jDrones

Reversing the roll channel disables throttle control

(Daniel Riley) #1

I’m trying to set up a skid steer rover and am having some issues with the radio inputs. When the roll channel is not reversed in Ardurover everything is fine (other than steering being backwards). When I reverse the roll channel I still have turning control but no throttle control. Of course an easy fix for this would be to just reverse the roll channel in my radio but all my other ArduPilot vehicles use the same radio profile with no issue so it seemed strange.

Video of the issue:

(rmackay9) #2

A dataflash log would really help find the issue but lacking that, I’d recommend checking the RC1_TRIM, SERVO1_TRIM and SERVO3_TRIM. They should all be around 1500.

(Daniel Riley) #3

I was thinking this could be a bug but if other people haven’t experienced it then its probably just an issue with my setup. Dataflash log here: https://drive.google.com/file/d/1gRhGB6msVLjjRzItiR9GYFRbiKtlH_PV/view?usp=sharing

Picture of the rover is attached. The idea is to eventually make it solar powered and boot up into Auto mode once the sun rises. It will just live out in the field and run through its waypoints all day. The speed is very slow, around 0.3 m/s and I’m going to need to gear it down even more because it does not have enough torque right now. Any advice on tuning? It seems to struggle quite a bit with driving straight to the waypoints. It could be compass related but the arrow in Mission planner seems to line up with its true heading really well. I already had to mount the GPS/compass far away from the frame since its steel. Is there a way to tell which mag is the external one and disable the internal mags? I mounted the PixRacer out on the end of the board too because right now it still seems like its using the internal mags. When I move a magnet near the PixRacer it throws compass errors but when I do the same to the external GPS/compass there are no errors.

Thanks!

1 Like
(rmackay9) #4

Hi @Daniel_Riley,

Thanks for the log. I had a quick look and here are a few suggestions:

  • ARMING_CHECK = 0. In general it’s best to keep this parameter set to 1 because it helps find setup issues.
  • RCMAP is being used to move around the channels from the defaults but MP’s RC calibration screen apparently does not handle this. In particular Throttle is on channel 1 which is normally for Roll which means the “reverse” checkbox next to Roll is actually affecting the throttle input. I think for now it would be best to:
    • Remap the channels in the transmitter instead of using RCMAP.
    • Uncheck all the “Reverse” checkboxes on MP’s RC calibration screen and do any necessary reversing in the transmitter.
  • Have you tried using MP’s Motor Test page to check the motor outputs are working correctly (i.e. motors/wheels are spinning in the correct direction)?