Servers by jDrones

Reversing ESC Calibration

I’ve been racking my brains for 3 days without success. I’ve converted a Hobby King Quantum Chaotic by installing a Pixhawk 2.4.8. Using Mission Planner and Copter 3.5.7, I simply cannot calibrate the ESC’s to work normally. The ESC’s that came with the Chaotic are reversible but ran in both normal and reversing modes using the original Madcow flight controller. In Mission Planner, I’ve tried synchronizing selecting Normal ECS type without success but OneShot 125 seems to work except the motors stop with throttle at center stick, spin correctly above center stick and in reverse below center stick. I’ve also tried calibrating the ESC’s manually plugging directly into Rx ch 3 without success. Reversing the throttle channel and reducing the trim by 50% also yielded no results. I’ve scoured the internet and cannot find a solution. I simply want the ESC’s to work normally without reverse. Can anybody offer any suggestions/solutions?

Direction parameters (bi or not) is usually a setting in the ESC firmware. At least that’s true for BLHeli.

I downloaded the BLHeli software, but, I’m unable to connect the ESC’s via the Pixhawk. Is there a compatibility issue between the two? Is there a work around?

A quick googling came up with this…
Specs:
Wheelbase: 400mm
Weight: 627g (without battery)
Motor: 2212 1300KV (DJI slot style shaft)
ESC: Afro ESC 30 Amp (SimonK firmware)
Flight Controller: Quanum Madcow 3D
Propellers: Gemfan Bi-directional 8in 3D Carbon Reinforced Propeller set CW/CCW Multirotor (DJI slot style)
Power distribution board: HobbyKing mini PDB with XT60 Connector
Transmitter: OrangeRx T-SIX 2.4GHz DSM 2 compatible 6CH Transmitter – Mode 2
Receiver: OrangeRx 415X

BLHeli Passthrough is only supported in Copter 3.6. But if you have SimonK firmware of course it won’t work. Buy some new ESC’s with BLHeli firmware.

Since the ESC’s are operating in reverse mode, I set the min throttle to 1500 and all seems to work fine. Does anybody see any potential problems with this setup/solution?

Hi, Im trying to do the same thing on a chaotic quad and having no luck. Did you set the throttle min to 1500 in the apm setup or transmitter?

Hey guys, how far did you get?

I got a Quanam Chaotic now too. I want to convert it to ArduCopter with my TauLabs Sparky 2.0.

How to do it with current reversible ESCs? I want to make use of original parts and I can’t get new parts anyways due to coronavirus lock down.

What is it like? Is it workable?

Yes, as an interim solution, I set the min PID to 1500 and it worked fine. Ultimately, I reprogrammed the ESC’s with Belheli software.

Good to know the SimonK ESCs can be reflashed to BLHeli! I’m going to do that too.

I did some searching and found we can actually get into the SimonK firmware settings and turn off reverse… Reverse can still be handy for a RC car.

Do you still have your Chaotic with AC? My FC fits inside the plastic canopy. No one suspects this toy looking quad is so capable. :slight_smile:

Still have the Chaotic but haven’t played with it for several months. Might pull it out again since we’re isolated with little else to do :slight_smile:.

1 Like

Just doing this now finally. :slight_smile:

Is it “THR_MIN” I need to change to 1500? It’s given range is -100 - 100.
https://ardupilot.org/plane/docs/parameters.html#thr-min

EDIT: I found “MOT_PWM_MIN” and changed it to 1500. The ESC’s still behave the same. :frowning: Am I missing anything?

These values appear to be percentages. It was a while ago but I seem to recall the values ranged from 1000-2000.

Will

Servers by jDrones