Servers by jDrones

Reverse thrust setup


(Clinton Young) #1

I recently decided to try out reverse thrust on my penguin but looking can’t find much documentation on it. I understand basically how to set it up for auto-land but what about using it in fbwa mode for example.
Also in Mission Planner when i set thr_min to -100 i get a warning that the value is out of range? is this an issue or not?


(jpkh) #2

What type of ESC you are using on your plane? As your ESC need to have capability of reverse spin your propellers.


(Clinton Young) #3

I have a turnigy plush 60A flashed with blheli bidirectional enabled. I’m confident i have the hardware setup correctly my query mainly concerns are how to use it. I’ve read how to use the bitmask use_rev_thrust to set which flight modes reverse is enabled but i see no option for fbwa. If i were to try to land in fbwa how would i use reverse thrust?


(Iam) #4

For manual throttle modes, like FBWA, you need to program your RC controller to take advantage of the reverse range. I programmed my Taranis so that the momentary switch activates reverse thrust if the throttle stick is at zero. The amount of reverse thrust depends on the position of a pot.


(Clinton Young) #5

Thanks thats exactly what i wanna do. I have a turnigy i10.

I think i have it figured out, i’m gonna do some bench tests while i wait for the weather to clear up.
Thanks iskess for your help.


(Clinton Young) #6

Did some bench tests and works well in manual mode. Tried in fbwa but reverse isn’t available.
Is fbwa supported or not??


(Iam) #7

FBWA and Manual modes to not control throttle. I don’t understand what you mean that reverse thrust works in Manual mode but not FBWA? It should be the same for both modes. Reverse thrust must be accomplished using programming functions of your RC handheld.


(Icarus) #8

I happened on this discussion and wanted to ask if anyone has used this feature on a ducted fan? Sorry, it’s a little off topic. A long time ago a guy was making ESCs that had this feature built in. Of course, on a ducted fan the voltage and current are much higher than your typical FPV plane.
Thanks!


(Clinton Young) #9

Its working now!! Maybe just needed a reboot but works beautifully now in FBWA.
Now if only the weather would cooperate :grin:
Thanks again iskess

edit: Also figured out that thr_min effects how much reverse thrust is available
i.e. -100 is 100% reverse -10 is 10% reverse
I originally had it set too low


(Roger Ronald) #10

I know this is an old thread, but it’s the exact topic that I’m looking for.

I want to do exactly what Icarus and iskess did. Allow auto-throttle in auto modes and have it available in manual/FBWA from the momentary switch on my FRSky X9D.

I see three things to configure. The TX radio, the Pixhawk, and the ESCs. What I’m concerned about is the interaction of the revised throttle range with failsafe.

Assume I set the ESCs so that 1500 is neutral (off), 2000 is full throttle, and 1000 is full reverse.

I can set the RC radio so that the throttle channel outputs 1500 when the throttle stick is all the way back and 2000 when the throttle is fully advanced. I can also set up an override to send the throttle channel below 1500 when the momentary switch is toggled.

Do I still keep the failsafe setting in the Pixhawk below 1000?

I assume thr_min and thr_max are just for automated flight modes.

Oh…one more question. Do the spinners for the props ever fly off when using reverse thrust? Do you put locktight on them (or switch to nylocks)?

Thanks!

RR


(Hunt0r) #11

I have never configured this, but I suspect your solution is correct:

  1. Set your TX to send a out-of-range-low throttle value (e.g. 950) if it turns off. (I can do this on my Futaba, I’m assuming all TX’s can…)
  2. Keep your RX Failsafe at something between that and your max-reverse-thrust, (e.g. 975) Thus if the PixHawk sees a value BELOW 975 (which even max-reverse isn’t that low) it will trigger the FailSafe.

Of course all of this is ground-testable to ensure correct behavior, but make sure to do it with props removed for safety!


(Roger Ronald) #12

Well…I tried it out.

The TX radio now sends 1500 to 2000 based on the throttle stick. If I toggle the momentary switch, I get 30% reverse thrust (about 1320 in PWM).

When I power up the plane, all works well. In manual modes, the throttles and special switch do exactly what I want… And the plane still recognizes failsafe when I turn off the RC radio.

BUT…as soon as the plane goes into circle for the failsafe (followed by RTL), it is telling the motors to spin full blast in reverse (PWM of 1000). That won’t work well! :slight_smile: This also makes sense as I hadn’t done anything to tell the Pixhawk that half the throttle control is for reverse thrust.

So, in the full parameter list, I set thr_min to -20% (it was previously at “0”). That seems to keep the motors quiet (they no longer go full blast in reverse during a failsafe event). But now they just sit there. While that’s better, having the motors stop for circle and RTL isn’t great either.

I’ve also commanded an auto mission that should execute (I tried going to a waypoint as well as trying to do a takeoff)…and there’s no throttle being given to the motors at all.
UPDATE: I wasn’t doing the auto mission correctly. Needed to reboot and start from scratch. Auto mode does advance the throttle for a takeoff command in my mission.
UPDATE2: If the Arduplane code that checks to see if the plane has moved prior to using the throttles in RTL and loiter still exists, that’s probably why the motors aren’t spinning up. I think I’m good to fly for further testing. I’ll let it do the auto-takeoff and fly my pattern mission…take it up to 100 meters and try RTL. If that works, I’ll do some dives in FBW-A using reverse thrust to see how much of a descent I can handle w/o gaining speed (or losing too much speed).

RR


(Hunt0r) #13

I’ll try to help if I can… but I’ve never tried it, and I don’t have equipment to reproduce your setup here. If someone else knows how to help, please speak up!

Q: What PWM value is sent to the PixHawk via the RX if the TX is turned off? (Presumably this value triggers the ArduPlane’s FailSafe)


(Hunt0r) #14

Another question: What is the value of your “Throttle Nudge” parameter?


(Roger Ronald) #15

I’m not positive what value is sent for failsafe. It doesn’t change on the status page on the flight data screen from whatever it was prior to the loss of the RC signal. But, it’s evidently working well since it always goes into failsafe when the radio signal is lost…and comes back out if the radio signal is recovered. I suspect that the PWM signal is going away entirely.

Nudge is enabled (value=1).

I currently don’t think I have a problem with the general config for reverse thrust.

RR


(Hunt0r) #16

Ah, okay! Mine works differently, sorry that I might have misled you. I probably don’t know enough to help any further, sorry :frowning: