Reverse button in radio calibration swaps lever functions?

Here is my latest head scratcher. I have been trying for several days to get a track drive rover to drive straight in auto mode. It mostly just counter-rotates back and forth in one place. It was suggested that I check the reverse box on the radio calibration page to try and correct this. When I check the roll box, the functions of the elevator and aileron sticks swap functions. If I also check the throttle reverse box, they switch back. Is this an indication of my problem of not being able to drive straight? I have tried so many things to cure this problem, I have forgotten where I started. I am currently using a APM 2.8 with internal compass. The motors are behind a 3/8" aluminium plate but the attitude on MP never seems to be accurate. I have ordered a 6m GPS with remote compass hoping this might help but I think I’m starting to grasp at straws. Any suggestions would be helpful. This thing is starting to kick my ass.

Please attach a file of your full parameter list to help troubleshoot your issue.

Thanks for looking at this for me. I have been trying to send the parameters list but it won’t allow the .param extension. I tried to change it to .txt but still no luck. I looked for a solution in the forum but did not find one.

Try attaching it as a zip file.

The parameters would be ideal and/or a log file.
I’m not following your setup exactly. You have a “tread/tank tracks” rover right? Are you using skid steering? How many motors does it have? 1 or 2 or more? If its more then 1 try and unplug the other motor and run with 1 and see that the tread moves in the correct direction when you move the throttle stick by itself and then the steering stick by itself. What channels are the ESC’s connected to on the APM? On your transmitter which channel is steering and which one is throttle? I am guessing from your post that aileron is steering and elevator is throttle? If so this implies your ESC support reverse - do you know if that’s true?

Clear pictures of your setup/cabling might help too.

Thanks, Grant.