Restless flight during Auto-Mode

Hi together,
I am trying to make my hexacopter fly in a smoother way in Auto-mode.
In stabilize it is doing quite well.

Firmware: 3.15
Here is a Video to show u the kind of trouble i think about:

Thanks in advance :wink:

My Parameters:

Your rate PIDs look bad. Loiter rate gain is way too high. I’d start off back on defaults, do an autotune, make sure your compass and vibrations are good, and then back off the STB_ and LOITER_ gains from the autotuned values to help smooth it out.

  • Autotune should be done with the copter in its lightest configuration and no gimbals or loose mass.
  • Compass should be on a stick and/or compassmot should be done.
  • Vibrations should be as low as possible

Also: this forum is for logs. Please post a log.

Sorry :slight_smile:

Here are the logs.
And also the logs of last thuesday when it crashed to the ground :frowning:
Does anybody have an idea what was the fail?


Hard to say without motor, compass or IMU logging, but usually when the copter just tumbles to the ground like that it is a hardware failure (motors, ESCs, props). Sorry I can’t be more helpful… Compass and motor logging would be very helpful in the future. Pixhawk has it enabled by default.