Servers by jDrones

[Resolved] What is the best firmware for the IR Lock precision landing?

Hello,

Which firmware version works best for precision landing with the IR Lock?

I use the Arducopter version 3.4.6, but the result is not satisfactory, the copter landed very often next to its target in RTL mode. Yet, with regard to the data, the beacon seems to be detected.

My configuration:
Quadcopter
Dropix (Pixhawk)
Sonar Maxbotic I2C
IR Lock
MarkOne Beacon

I have attached my logs:

https://drive.google.com/open?id=0B4_NMRWainOKS3BDRjJpelF3akU

If someone can help me, it’s cool !

Hello,

I’ve done new tests.

I first tried to load Arducopter V3.5.2 but could not install it.

I upload the firmware provided by the IR Lock team (Arducopter_PL_Quad_3.3.3_rc2) and overall it works correctly. I tested in Loiter and Land mode and it’s OK, however, in RTL mode, it does not work.

Question: Is there a newer firmware running in RTL mode?

Hello,

I installed the latest version APM: Quad v3.5.3, but MP shows me that the firmware is not recognized when I put my quadcopter on.

I installed APM: Quad v3.4.6, and actually my IR Lock does not work with, neither in Loiter mode nor in Land mode. It works perfectly with version 3.3.3_rc2.

I would have liked to use at least a version 3.4.x firmware and especially that the precision landind function works in RTL mode with IR Lock.

Am I the only one with this type of problem?

Do you have any advice for me?

@Dorian

Thank you for sending me the link to this thread. I hope I can get back to you soon.

Best,
Thomas

@Dorian

Sorry for the delay. I analyzed your posted log file.

I have two suggestions:

I would strongly recommend switching to the latest ArduCopter firmware. This particular flight was conducted with V3.4.6. My main concern is that some of the older firmwares use a newly-developed EKF for estimations in the precision landing controls. I have observed that the precision landing EKF has produced mixed results: great in some cases, and poor in some cases.

In the latest firmwares, you can disable the precision landing EKF by setting the parameter PLND_EST_TYPE = 0 (RawSensor). This parameter does not exist in V3.4.6. The RawSensor estimation type seems to provide more consistent results for a broader range of copter setups.

ALSO,
We recommend using a better rangefinder (SF20/LW20/SF10A). It looks like your rangefinder data is not good, especially at higher altitudes. This results in bad pX/pY calculations.

I hope this is helpful.

Best,
Thomas

Hello Thomas,

I will follow your advice by trying to install a more recent firmware version and by disabling the landing EKF.

Regarding the rangefinder, my problem is that my quadcopter is small and I’m not sure I have enough room to install a lidar.

Thank you for your answers and the time you give me, I will be able to advance on my project !

Best,
Dorian

I ordered an SF20 and I hope to be able to install it in my chassis, this model is smaller than the older versions I was interested in before.

I managed to install APM: Copter v3.5.3 Quad.

I made two flights:
a flight with PLND_EST_TYPE: 1
another with PLND_EST_TYPE: 0
and the result is the same, it does not work with precision landing.

Logs with v3.5.3:
https://drive.google.com/open?id=0B4_NMRWainOKckdrczB5anEwejg

I installed Arducopter_PL_Quad_3.3.3-rc2 and it works.

I will wait to receive the SF20, but I do not think it solves the problem with firmware v3.5.3

@Dorian

Thank you for the update.

I checked the linked log file, and I did not see any rangefinder data. Without the rangefinder, the precision landing controls will not work (especially in 3.5).

-Thomas

OK, thanks,

I’ll wait for the SF20 and install it all correctly

Thank you again for your help

1 Like

Hello,

I have received the lidar SF20 that I have ordered from you.
I installed it in I2C on my quadcopter, but it does not work.
I tested it with firmware v3.4.6 and v3.5.3 and it does not work.
I checked 100 times my connections and everything looks ok

Is it necessary to set the lidar with a Lightware program before installing it on the copter ?

Is there a light on lidar lidar when it is powered ?

Thank you in advance for your answers

did you set the range finder type and address?
http://ardupilot.org/copter/docs/common-lightware-lw20-lidar.html

Hello,

Yes, I followed the instructions in the documentation.

I will try to connect the lidar to the serial port and I will come back to you to tell you what it is.

Hello,

I tried plugging the lidar into serial port 4, but it still does not work.
I have a message “Bad LIDAR Health”. In the “Status” tab of MP, "sonarrange and sonarvoltage remain at zero.
I just ran the engines a few seconds to be able to provide a log file, I do not know if you’ll be able to help with that?

https://drive.google.com/open?id=0B4_NMRWainOKM3pBQ3RraEFCdFU

I wonder if it is not the lidar by itself that does not work.

Do you know if there is the possibility of testing the lidar with an Arduino UNO ?

Hello,

Problem solved after many tries!
There was a hardware problem between the flight controller and the lidar.

I use the APM Copter v3.5.3 firmware, the SF20 lidar and the IR Lock system work perfectly.
I still have some settings to do for the landing and everything will be ok!

Hello
I am facing bad vision problem, I feel it is due to firmware and pixmon version.
So kindly provide working pixymon and .hex file, early response s appreciated.

Is it mandatory to use rangefinder, if yes provide the documentation for that.

@Akash_Kumar

Good Day,

The correct firmware and software versions are included in the tutorial. The tutorial also requires a rangefinder. The rangefinder installation instructions are included in the ArduCopter wiki.

https://ardupilot.org/copter/docs/common-rangefinder-landingpage.html

Best,
Thomas

Hello Dorian,
I have exactly the same problem as you described (SF20 and DroPix board).
Can you help me how you solved the problem?
BR David

Hello David,

I do not remember exactly what I did, today I use a Cube Black.
I remember I connected the lidar to a serial port because it didn’t work on the I2C.
Be careful to have the right lidar cable

Hello Dorian,

thank you for your answer now it’s working.

Servers by jDrones