"Relaxed" GPS Lock settings

i have some trouble to get 3d Lock, thats strange becaue i have the green light blinking which means it has GPS signal, but it seems not goot enough. Is there any setting for “relaxed” GPS positioning? i dont need it very accurate.

maybe your HDOP isnt below thresh hold GPS_HDOP_GOOD what kind of gps are you using and is it I2C or Can?

Im using a “Ublox MAX-7Q GPS-Modul” im getting 6 Satellites. Can i check some values ? And it is I2C

I also have a problem with getting GPS lock. I am using Beitian 880 with Matek F405 CTR running Copter 4.0.5. I took my quad out to an open field and powered it up for almost 20 minutes and it did not even get 1 satellite. HDOP was 655.35. Satelite 0. GPS module was blinking blue.

Without taking off, I switched flight mode to Loiter it then shows EK2 still initialising.

Something else is wrong with HW or setup. Does your GPS show up in MP? “like GPS: No Fix”

I’m using the same and it works very good, it gets 3D lock in seconds.

It does not show up in MP. No 3D fix, no GPS, no satellite…

Good. May I ask what version of Arducopter you are running? Which serial port your GPS module is connected to? What baud rate is GPS setting in Mission planner? Thanks.

Im using FW 4.05, its connected to the combined GPS/I2C Port of my Pixhawk mini
Its configured on Serial4 Baudrate 38400
Maybe you could check the wiring, for Pixhawk mini i had to do some rewiring using tx/rx and 5V/Negativ

Another thing you could check is the Compass found correctly ?

Sounds like the TX and RX are not reversed.

Use Serial 3, 115200. Then check connections, maybe swap RX/TX

If you have not set up 115200 and saved on your Beitian GPS try 38 as standard for this GPS Serial3_baud :slight_smile:

I downgraded to FW4.0.0 and wired tx and rx from TX1/RX1 to TX1/RX3, baudrate at 57600, instantly it had 10 satellites and GPS fix inside the house.

  • SERIAL1 = Telemetry1 = USART3

I haven’t tested the compass yet.

I did not revert those. I rewired it to

  • SERIAL1 = Telemetry1 = USART3 and it works

Surprisingly it is working when I rewired it to Serial 1. Baud rate at 57600.

Did you see any gps debug message in mission planner messages tab? If you can’t see any, it is related with a wiring or baud rate error most of the time, and very low probable cause is the module is damaged.

I did not see any messages relating to GPS when it was wired incorrectly. Now that is is wired correctly so I see the GPS module is being detected by MP.

1 Like