Receiving messages from non-autopilot components

I have a drone with a parachute that broadcasts heartbeats with component ID 161. This is what I see with the parachute connected:
image

The autopilot is sending a heartbeat with mode Loiter, and the parachute sends a heartbeat with custom mode 1, resulting in a bunch of spam. I want to configure MAVProxy to only process messages from the autopilot (ID 1) and ignore the parachute. Setting --target-system=1 --target-component=1 doesn’t seem to change anything. Is that the correct usage?

Yep, I had the same issue. See pending PR for a fix: Allow Periph components to be used by stephendade · Pull Request #1116 · ArduPilot/MAVProxy · GitHub

Note the PR only fixes for component id 158. I’ll see if I can generalise for all non-autopilot components.

1 Like

Aha, I see, thanks. In the meantime, I found that setting SERIALx_OPTIONS = 1024 on the flight controller to disable MAVLink forwarding avoids the problem for now, but it also means that the companion computer won’t be getting any of the important messages we actually do want, though. Your PR is more like what we’d need.

Edit: If not this, then what are the --target-system and --target-component options for?

I’ve re-done the patch for the general case. See if it works for you.

1 Like

Great, thanks, I’ll try it out this week.