Receiver stops working on subsequent power, can't arm quad

Have had good experience with APM v2.5x and installed one of my fresh APM v2.5 boards (assuming it is 2.5.2 since it was purchased right before 2.6 was released) on a new quadcopter (frame printed from a 3D printer).

I had to update the PPM encoder firmware and this was first, then I installed APM v2.5 and GPS and telemetry with a Spektrum AR7010 receiver. Went to radio calibration and was able to get the radio calibrated, and was also successful in accelerometer calibration and compass calibration.

Got the motors to spin and the new slow spinning motors on arming is neat. Watched the motors turn on and off and was able to spin them up.

My issue: after powering-down the APM v2.5 (with FW v3.1 on it and new PPM firmware), the radio no longer responds, so I cannot arm the quadcopter. The issue is solved only during while power is applied; when I kill power and reapply, the receiver shows a linked connection but nothing is responded to on the GCS software.

My solution (so far): The only thing I can do to get the radio to respond is to preform an accelerometer calibration routine again; then, the radio works like expected and the motors arm and spin, etc. However, after cycling power, I no longer have access to the radio until I perform an accelerometer calibration.

I have tried to erase the EEPROM–same results. The wizard likes to get stuck on some attempts when the radio is stuck, but I was able to get through the whole wizard installation with all green boxes, thinking that maybe a wizard active flag was stuck in the APM’s EEPROM.

Other things I have tried was to go to advanced PID full parameter list and “write” the parameters, thinking somehow the accelerometer calibration didn’t stick.

Subsequent radio calibrations fail since the radio parameters are all at one level and don’t change. I repeat that the only thing I’ve found was to re-perform an accelerometer calibration. How can I get this to stick so that APM knows that it’s okay to go?


it could be some kind of hardware fault. what would be good is an rlog from the mission planner or you could try connecting through the terminal window or the arduino serial monitor.

Thank you. I was too focused on the firmware. It was indeed a hardware issue and stemmed from something wrong with the connection between the AR7010 and the satellite receiver.

I replugged the satellite and rebound the receiver and now the unit works predictably.