Receiver radio connected to Arduino not responding

Hi everyone,

I have this question for my university project. Basically, this setup would be a remote control using a pair of 915MHz radios. I use my computer to send a string via the transmitter radio plugged into the USB port to a receiver radio connected to another Arduino board. I have been using the terminal in Mission Planner as well as CoolTerm to send strings via the transmitter radio. And the receiver radio connected to the Arduino would receive these strings. Finally, the Arduino would perform certain actions depending on the string received.

I know the transmitter radio is sending the string data, because every time I hit enter, the red LED lights up briefly. However, I still cannot get any response from the receiver radio connected to the Arduino. Both radios have the solid green light, so I know they are connected.

For the Arduino, I am using the RX and TX pins and connecting them with the same pins on the radio. In the software code, I am using the SoftwareSerial library, which takes two pins on the Arduino and emulates them as a Serial port. You can then read values from those pins.

However, every time I send data from my computer, the receiver radio doesn’t seem to have any response. When it receives data, the red LED is also supposed to flash, right? And the Arduino board is still reading values of -1 from the receiver radio.

I am not sure what my problem is here. I’ve tried swapping the RX and TX connections to the Arduino, but to no avail. I know these two radios work, because when I skip the Arduino and connect both of them to different computers, they send and receive data without a problem. It’s just the Arduino connection that is giving me problems.

Has anyone successfully integrated a receiver radio with an Arduino? Any tips would be helpful! I can provide more specific information if needed!

Thanks!

This should work. I think the wire you are using to connect it to the Arduino is bad.

Yes, both sides should see the red LED blink as data is passed.

I have a setup where I have an ESP8266-01S connected to the Radio using a special cable from 3DR.

I connect my phone to the ESP8266 and can then use Tower to talk to my Copter which has the other radio.

I checked my connections by using a TTL-232R-3V3 cable connected to my computer.

Mike

What is the special cable you are using to connect the ESP8266 module to the radio?
As far as my wires go, I’m just using standard jumper wires that came in the Arduino kit. They’ve never been a problem for me.

Here is a picture of what I have.
ESP8266 and 3DR Radio

Mike

1 Like

My setup is still not working for some reason.
For the receiver radio, it works perfectly fine when I connect it via its micro-USB port to my computer, meaning it receives the sent data no problem. The orange LED flashes every time it receives data. I can view the received data in Mission Planner, Arduino Serial Monitor, and CoolTerm.
The problem is when I try to connect the receiver radio to Arduino. I am thinking that the radio is not receiving when it is not connected via USB cable. I found that when I only power up the radio with no other connections, the orange LED does not flash, meaning that no data is being received. The same thing happens when I connect the RX and TX pins to Arduino. The receiver is only powered up and connected to the transmitter (solid green LED), but it’s not receiving (no orange flashing LED).
Is there a setting that I need to change when configuring the radios in Mission Planner? I feel like the receiver radio is only receiving when it senses that it is connected to a serial port (USB port). I’m very confused now, because the TX pin works fine for writing values to transmit, but for some reason the RX pin doesn’t work for reading values that are received.

Sounds like you need to get a USB to serial cable and test your wiring out.

These radios have an AT command set and you can put them into command mode by sending +++

After that there are commands you can set to see if the radio is working. Adrupilot advanced config

There are some radios depending on how there powered up go into boot loader mode looking for new firmware to be loaded if the CTS pin or something is held low. I only have POWER, GND, Tx and Rx connected.

I also have one of these cables to test with. TTL-232R-3V3

You can’t use the Serial monitor in Arduino to send the “+++” because it adds extra characters. You need to send just three plus symbols and wait for an OK.

Also check your pinout. I was able to power the radio with Tx as my GND pin. The radio powers up but nothing works. Sik Telemetry Radio

Mike

1 Like

Friends I have some doubts with this. I use 3dr radio module for my Copter. The air module has serial port connected in Pixhawk flight controller and ground module has usb port connected in my Windows 10. I tried to connect them using mission planner. Both were loaded settings in the MP but not connected each other. I accidently clicked update firmware. After that the air module is not connecting with mission planner. Receiver side went cannot access. I dont know why. May be the ground module were only updated. I dont have a ftdi or any usb to UART converter. So I searched for the solution and I got arduino can be used as usb to serial converter. I connected the air module to Arduino UNO as mentioned below
Module 5v to arduino 5v
Module GND to Arduino GND
Module Tx to Arduino Tx
Module Rx to Arduino Rx
and Reset and GND in arduino are connected.
The program used is
voil setup()
{
pinMode(0,INPUT);
pinMode(1,OUTPUT)
}
void loop()
{

}
First time the program didnt upload because I connected the whole setup in Arduino board. I removed all the jumpers and air module from the arduino. Then the program uploaded. May be this is because while connecting to Rx and Tx the program may not upload. After uploading the program I reconnected the 3dr air module. I tested AT command as shown in the internet. Also my ground module is not connected in laptop. But the AT command is going blank when clicking ENTER. The arduino is detected in the Port(in my computer COM8). I opened the Mission planner and selected ‘SiK Radio’ option from ‘Optional Hardware’ from ‘Initial Setup’. Selected COM8 port and tried to ‘Load Settings’. But It is showing ‘Failed to enter command mode’. Same tried in SiK radio Config software but same problem. Please any one tell me how to connect the airmodule in Mission planner or SiK radio Config using arduino as usb to serial. So I can upgrade the version to match the ground module.