Reaching waypoint causes motors to STOP

Have a problem with my APM 2.5.
Just finished a building of a quad, everything works fine, stabilize, althold, then loiter, although it has the “toilet bowl” effect, in no wind it’s almost stationary, but in wind sometimes it climbs. I think it’s because of the barometer is not covered perfectly.
Anyway, this is not the problem. I tried to fly a really small mission today, just to test it.
Set it to loiter, then set it to auto. It started to fly to the 1st waypoint. I set 15m for altitude, but it flew below 5 meters for some reason. That i could live with. But when it reached the waypoint, it just throttled down. Telemetry got disconnected, it crashed in a field about 100meters away. I armed it again, then it popped over the horizon, and landed at my feet in stabilize mode.

Next i set the alt to 25 meters, and this time it reached ~15-20m. However when it reached the waypoint, again, throttle to zero. i quickly switched to stabilize, and it didn’t crash luckily.

In the logs i see when it reaches the waypoint, the BARO altitude is raised(not logic imo), and the board commanded the 0 throttle, although the throttle on the tx was at ~50%. No mechanical failures, it works great in anything but auto mode. I can’t see the connection between a waypoint and the barometric altitude.

Attached log, anyone could help me in this?…01-56.log?dl=0

Looking at the log, i have 2 questions.

  1. The Vcc looks low to me. The board is powered via an esc’s bec, however it works okay in anything but auto mode.
  2. Logging is set to “Nearly all”. Could this(and maybe the low Vcc) overload the APM? Maybe then the waypoint navigation is too much for it, that’s why it shuts off? Are there any ways to see the current load of the board in the logs or in realtime?

Thanks, and sorry for the long post.

The link to your file doesn’t work for me

My bad, here it is:

Need to know what your mission was. In some version of the firmware when it reaches the last waypoint it switches to loiter mode and will fall from the sky if the throttle is not up.


Throttle was around mid. I didn’t save the first mission, this is the second try. Attached mission file, it was a simple 2 waypoint and a RTL command at the end.
Altough it just only reached the first waypoint.

from auto analysis

Test: Autotune = UNKNOWN - No ATUN log data
Test: Balance/Twist = GOOD -
Test: Brownout = GOOD -
Test: Compass = FAIL - Large change in mag_field (61.23%)

Test: Dupe Log Data = GOOD -
Test: Empty = GOOD -
Test: Event/Failsafe = GOOD -
Test: GPS = FAIL - Min satellites: 0, Max HDop: 2.09
Test: IMU Mismatch = NA -
Test: Parameters = GOOD -
Test: PM = WARN - 2 slow loop lines found, max 6.49% on line 38935
Test: Pitch/Roll = FAIL - Roll (-179.22, line 54231) > maximum lean angle (30.00)
Test: Thrust = FAIL - Avg climb rate -5.98 cm/s for throttle avg 725
Test: VCC = FAIL - VCC below minimum of 4.6v (4.541v)

the gps one is because the file starts with no sats, so not a worry.

Not sure if this is the cause but your Vcc is pretty low at 4.6V av dipping to 4.56V. It seems to carry on running, but is too low for comfort.

you can see the rc outputs drop before you retake off in loiter/stab, so the brain asked for it, so it doesn’t look like a brown out, especially as you took off after and its in the same log. the rcouts don’t look so eqqual later in the flight, maybe something twisted in the crash.

looking at ctun, baralt rises (Baro alt does this also) as you lose alt…so it looks like it thinks its climbing and drops the throttle.

You baro needs to be covered and sheltered from light. Is there a chance it could have had light get onto it mid flight?

Yes, there is a possibility that the barometer got some “headwind”. Working on covering it.
But is it normal for the board to just simply cut the throttle? Not logic for me, lowering it would be okay, but cutting it in mid flight, not good. Anyway, will try to cover it, then give it another try.

I didn’t see any damage on the frame, i will look at the motor angles, but it hovered good after the crash.

Vcc is low, because the board is powered from an ESC. Powermodule is on the way :slight_smile:

Also, as i asked, do you think it’s possible that the board is overloaded, and it just reset or something?
Thanks for the help!

If it thinks its climbing at the rate yours thought it was it will reduce throttles. Your baro data was very bad, you can’t expent it to cope with very bad data :slight_smile:. Its not just wind, light can affect the baro hence my question about light.

I don’t think it got overloaded, just confused by the baro.

sent from my phone so apologies for any typos

Okay, i have no experience with the APM so i believe you:) I just didn’t think it would cut throttle because it’s confused :slight_smile:

However, just a random idea, is it possible to just disable the barometer and use only the GPS alt in AUTO mode?
So the barometer would only be used for landing and althold maybe. I think GPS is more reliable than a barometer, the ~2m accuracy is enough for flying over a field at ~20meters. I know it’s not possible in the GUI, but is it possible to alter the code, or has anyone did it before?

Of course i will cover the barometer. Right now it’s covered only with foam, so both light and headwind could have been an issue, but even if it’s sealed from everything but the pressure, what if it hits a strong thermal?

Please don’t make my words worse by using them out of context :slight_smile:…I have taken the time help you resolve your issue, I am just a hobbyist and have no affiliation with this forum or 3DR.

By confused I mean it is trying stop it self from thinking it is going to hit the moon in several minutes when it wants to be at a constant height…yes I am being facetious…but any system is only as good as the data it reads. Would you be able to hit the floor running if you were blindfolded?

You could muck about bodging it making it use GPS alt but it won’t fly very nicely (Tuning EKF params). GPS alt isn’t actually that accurate (2m horizontally maybe on a good day, not vertically) and is pretty noisy meaning your copter will jump about. Baro if not crippled is accurate in a relative way…it is good at detecting relative height changes (as long as other affects are removed), it isn’t absolutely accurate as atmospheric pressure changes over time. Combining GPS, baro and estimated alt change using the accels is a good solution. Just get your baro working by protecting it and you will enjoy the same good performance everyone else gets.

Multicopters don’t thermal :slight_smile:…the climb rate yours thought it had would never be caused by a thermal (I bet a glider wouldn’t either! lol), hence no one thinking that the code needed some form of protection against such climb rates if they were real. The outputs didn’t actually fully hit zero in your logs anyway, although that doesn’t mean the motors didn’t stop.

If you want the best accuracy below 40m consider lidar lite ( although I have no experience with it and no real need for me other than curiosity, GPS/baro is good enough for my general use).

I didn’t want to “make your words worse” in any way, sorry if you misunderstood me, i’m really greatful for you for helping me! :slight_smile:

It was just an idea, since i’m paragliding and i don’t really trust barometers for my altitude, it can creep too much, that’s why i prefer GPS alt. However, if it’s only me, then the problem lies in my setup ofcourse, not in the software :slight_smile:

Thanks again, i will update, if it works! :slight_smile:

No worries, I wasn’t too serious about it, sorry if I came across as over reacting. Glad to hear you have real feet off the ground experience…that’s more than me. Would like to try it, but I have enough hobbies that I spend too much money on :slight_smile:.

I think GPS is probably quite good for you feet off the ground needs…as you won’t react to every altitude change like a computer will. I wonder if your GPS vario has a baro too for smoothing. My GPS I have for cycling has a baro that actually improves the accuracy and resolution allowing better total ascent and climb rate to be measured that the GPS alone version won’t allow.

I recently started looking at the EKFs for the the Baro/GPS, and I made it more sensitive to GPS and although it was better at ignoring aerodynamic affects changing pressure seen by the baro, it does fidget up and down a lot more in a steady loiter.

Yeah keep us updated

Finally i figured it out. The barometer is somehow faulty.
Ordered another APM, installed it, now its working as it should:)

Don’t know how could i fix the old one, if i put it in a closed plastic box, almost airtight, the barometer still climbs slowly. Checked the 3.3V regulator, it’s okay.