Servers by jDrones

RE: Getting the BBBlue Connected to Mission Planner/Linux Hardware with ArduCopter 3.6

(De Funct) #1

Hello,

I have Mission Planner on a Win 10 machine. I have a BBBlue w/ ArduCopter 3.6 on it. The BBBlue is a Linux Machine.

I am receiving some print statements on my console via PuTTY but I cannot connect to Mission Planner yet.

MPU: temp reset IMU[0] 9171 -13021

The above code is my print statement that prints to the console on PuTTY.

Seth

P.S. I have tried manually connecting via sudo ./arducopter -A MyIPaddress:14550. This command only inflates the MPU warning from above, i.e. which I think is just the ArduPilot software working. Still, connecting to Mission Planner has been void. I tried a com port and a baud rate. I tried w/ my receiver, i.e. X8R from FrSky. No connections yet. Please send guidance.

(Michael Oborne) #2

check the windows firewall, and allow MP. it might be blocking the udp packets to your pc on port 14550.

(De Funct) #3

Hello,

Okay! I will check Windows firewall. I will allow MP to pass the firewall. Thank you.

Seth

(De Funct) #4

@Michael_Oborne,

Sir, that was not it. I did have to enable, via the firewall, MP on my Win 10 machine. I first allowed all ports and then I tried to only allow port 14550.

I received some errors while connecting. I will try to reproduce those same errors and report here if you are already familiar w/ the errors I am receiving.

Seth

P.S. I think I may have gotten signed in on MP w/ SITL. I think this is all I needed. I will check.