Servers by jDrones

RE: Compilation Errors While Compiling and RC 4.0 for the BBBlue

Hello,

I seem to be getting many compilation errors while compiling on a 32-bit arm computer. I am compiling RC 4.0 from ArduPilot on the BBBlue to see if things work out or if there are errors to be found.

Anyway…there is a better way. I am not taking that route right now.

Are there any plans to use waf w/ Python3 to compile RC 4.0 on armhf boards?

Seth

P.S. I see some libraries are still only compatible with Python2 from a guide I have been following. There is a new image available online from the beagleboard.org/latest-images people. The image is good. I am just seeing error after error and wondering if I should downgrade to an older RC or if anyone else is having compilation issues, too.

Waf should already work with Python3 (I’ve been doing so for a few months now on my desktop, not a BBB). What errors are you getting?

Hello,

@stephendade: Here are some errors during the current compilation of RC 4.0 w/ waf from python2. I tried w/ python3 but I found that there were more errors like these during compilation…

In file included from ../../libraries/AC_Avoidance/AP_OAVisGraph.h:4,
             from ../../libraries/AC_Avoidance/AP_OADijkstra.h:7,
             from ../../libraries/AC_Avoidance/AP_OAPathPlanner.h:8,
             from ../../libraries/AR_WPNav/AR_WPNav.h:6,
             from ../../libraries/AR_WPNav/AR_WPNav.cpp:18:
../../libraries/AP_Common/AP_ExpandingArray.h: In instantiation of 'const T& 
AP_ExpandingArray<T>::operator[](uint16_t) const [with T = AP_OAVisGraph::VisGraphItem; uint16_t = 
short unsigned int]':
../../libraries/AC_Avoidance/AP_OAVisGraph.h:53:71:   required from here
../../libraries/AP_Common/AP_ExpandingArray.h:107:16: warning: cast from 
'AP_ExpandingArrayGeneric::chunk_ptr_t' {aka 'unsigned char*'} to 'const 
AP_OAVisGraph::VisGraphItem*' increases required alignment of target type [-Wcast-align]
     return (const T &)(chunk_ptrs[chunk_num][chunk_index]); 

I am seeing these types of errors but it seems the build persists w/out incident. I tried to set up this idea:

sudo apt-get install g++ make pkg-config python python-dev python-lxml python-pip
sudo pip install future
git clone https://github.com/ArduPilot/ardupilot
cd ardupilot
git branch -a  # <-- See all available branches.
git checkout Copter-3.6  # <-- Select one of the ArduCopter branches.
git submodule update --init --recursive
./waf configure --board=blue  # <-- BeagleBone Blue.
./waf
sudo cp ./build/blue/bin/a* /usr/bin/ardupilot

This idea is from github.com/imfatant/test.

Seth

P.S. If you see what I am doing incorrectly to receive the baro not initialised error when setting up Mavlink, please apply some knowledge here. I sure could use some insight or guidance.

Those are compilation warnings from the ArduPilot C++ code. Not related to Python.

Can you try the latest master code? Those warnings have likely been fixed.

EDIT:
Are you getting a ‘finished successfully’ message at the end? If so, then the compilation worked fine.

Hello Sir,

Seth here. Yes sir, the compilation finished w/ “finished successfully.”

Seth

P.S. I am still receiving this error now:

SBUS FD -1 115200 FD -1

Looking at the ArduPilot source, it appears to be having trouble initialising the RC Input.

Hello @stephendade,

I am just going to start from scratch and see if I missed a step.

Seth

Hello to @stephendade and Anyone Else Following Along,

This file needs to be typed up w/ my development desktop or the BBBlue IP Address?

sudo nano /etc/default/ardupilot

TELEM1"-C /dev/ttyS1"
TELEM2="-A udp:<target IP address>:14550"
GPS="-B /dev/ttyO2"

I have compiled the source of ardupilot/arducopter correctly. It is showing that the service works and the user LED is flashing red.

Seth

P.S. Where it states above, what exactly does target IP address mean? I am asking b/c I am trying to connect to Mission Planner on the Windows 10 edition.

That’s the network IP address of the windows computer, probably 192.168.something.something.
Open a command prompt in windows and type “ipconfig”, and it’ll show. You want the IPv4 address.

@stephendade and @james_pattison,

Thank you for your guidance and support on this subject. I just got it up and running.

Seth

P.S. I will have to calibrate my ESCs now and try to get some fly time in if I can configure everything.

Hello Everyone,

Well, I got the calibration done b/c of this person I met online at Freenode #beagle.

Anyway, the BBBlue needs to be on its edge and not turned left like a left turn on a plane. Blah. Anyway, the calibration steps have concluded and are done. Time to fly, soon.

Seth

Servers by jDrones