RCIN - RCOUT Delay on Ch3

(Don’t hijack a topic, start a new one :wink: ) Thx :thumbsup:

2016-11-19 16-01-21.zip (2.1 MB)
3.4.2 is even worse with this issue.
Spooling up has suffered a setback - quite close to 2 second response time from my input to the motors spinning.
And even then, motors 3 and 4 do not spin until I get to about 30% throttle and even then, they are lagging…not catching up.

Too many “new” things going on to compare to 3.3.3 issues.

Logs uploaded as requested

Not a bump - additional information

I just completed a Tarot 680pro HEX build and I just performed the maiden flight with displays the SAME behavior as my 550 HEX and 450 Quad.

Motors will not shut off on touchdown during automated landings.
And, there is still a throttle delay between RCIN and RCOU Ch3

Let’s review;

450 and 550 on 3.3.3 - motors will not shut down on automated landings/ delay between throttle action and motor spin as shown by log file.

450 and 550 on 3.4.1 - same behavior.

450, 550 and 680 on 3.4.2 - same behavior

550 on 3.4.3-rc1 - putting the throttle to 100% and pulling back within a split second, the motors are so delayed they react after the throttle is back to 0%

And this behavior is seen with the release of 3.4.3
Motors will not shut off on touchdown during automated landings.
And, there is still a throttle delay between RCIN and RCOU Ch3
Someone please help.
I cannot get the same behavior as my friends do with their 2.4.8 Pixhawks.

And, this issue has been going on for too long - OP below:

So, the normal, unaltered behaviour of 3.4.x is the one here from this https://youtu.be/ua8OLkIvyas?t=5m08s

where the automated landing deploys the landing gear automatically and stops the motors after landed.

I would suggest that you reset your config and start from scratch. To do that flash a ArduPlane version reboot and then flash again Copter.

The delay you speak on TH is really dependent on which flight mode is active, because most of the modes are like a fly by wire system, where the system receives a order and tries to comply within a given set of parameters with the desired user input.

If you want a more “direct” mode try Acro.

This is a completely wiped firmware load by loading ArduPlane then 3.4.3 from MP.
That has begun to be my common practice to loading firmware.
This happens with the following flight modes:
Stabilize (delay in energized motors stopping from being energized)
PosHold with zero throttle descent.

I see your video and that is exactly what I get.
However, I am now checking with the other group to see if they can link me the video of the shutdown I described.

Shooting from the hip here, but make sure you don’t have any delay programmed into your throttle channel on your TX.

Verified, no delay there.


I installed my CX-20 Tx/ Rx on my DJI550 - same throttle/ LAND delay.
Still waiting on that friend’s video of the instant shutdown on LAND

Update - This is why I got PixHawks for my crafts but I do not see this landing behavior.
Motors shut off instantly on contact (listen to the motors de-energize on contact)
They still spin but they do not have power to them - mine do as seen in the previous video.

And even more evidence of the motors shutting off instantly on landing.

Please…this issue was originally posted in September and is still not resolved.

This will hardly be complete, but… Things I see.

It’s not an ESC setup issue, but I do like to use the MOT_SPIN_ARMED and MOT_SPIN_MIN parameters to avoid “soft start” features in the ESCs. You have them zeroed. This is also why they start so late as you raise the throttle from bottom in STABILIZE.

This behavior is odd.
C3IN, THI, and THO are synchronized as expected. RCOUT 1 through 4 clearly are late to the game.

I also like to reduce my DISARM_DELAY from 10 to 5ish for auto landing/disarm. This will not influence the throttle issue you are seeing, it would just “idle” for less time on ground. The way you have the MOT parameters setup, you don’t even see the “idle” after arming, or before disarming.

After seeing your non-standard MOT setup, I think the previous suggestion to go back to stock parameters and bench test is warranted.

This flight looks pretty good though.

I’m curious if the perception of delay is changed by setting these up to something in this ball park.


Minor testing with the following param changes:

  1. I do not like spin armed
  2. with these settings, the other bounce effect is still there - where I increase motor speed quickly and reduce. It sounds like the motors are getting a double increase before reducing but the motors still have a delay increasing.
  3. Automated landing does not shut off motors.

2017-01-10 11-00-53.bin (740 KB)
2017-01-10 10-57-31.bin (1.4 MB)
1 12-31-1999 6-06-14 PM.bin (1.2 MB) Indoor throttle up
2 12-31-1999 6-08-36 PM.bin (1.2 MB) Indoor flight

The log bitmask seems to have changed. RC IN and OUT are not logged, unfortunately.

Sorry about that:
2017-01-10 16-14-54.bin (367.6 KB) Throttle up - no flight
2017-01-10 16-17-55.bin (1.1 MB) Land Mode

Not had a thorough look through the logs, but the motor delay when throttling looks normal to me. The slight extra ‘twitch’ of rpm I think is because the AP sees a none 0 pitch / roll attitude and is responding to that.

The auto land delay motor shut down looks as if the ‘am landed firmly on the ground’ test is un-sure the craft is on the ground. this will delay the motor off. I see a little spike in the baro pressure drop just after touch down @17942, this is telling the AP the altitude has just increased a little. this may well delay the motor off as the AP is not convinced the craft has landed. This may be due to ground effect and prop wash. the pressure from the props may be changing the pressure on the ground which the baro detects and the AP reads as a slight altitude increase causing this.

I will do that ground effect adjustment tomorrow and report - thanks!