RCIN - RCOUT Delay on Ch3

This will hardly be complete, but… Things I see.

It’s not an ESC setup issue, but I do like to use the MOT_SPIN_ARMED and MOT_SPIN_MIN parameters to avoid “soft start” features in the ESCs. You have them zeroed. This is also why they start so late as you raise the throttle from bottom in STABILIZE.

This behavior is odd.
C3IN, THI, and THO are synchronized as expected. RCOUT 1 through 4 clearly are late to the game.

I also like to reduce my DISARM_DELAY from 10 to 5ish for auto landing/disarm. This will not influence the throttle issue you are seeing, it would just “idle” for less time on ground. The way you have the MOT parameters setup, you don’t even see the “idle” after arming, or before disarming.

After seeing your non-standard MOT setup, I think the previous suggestion to go back to stock parameters and bench test is warranted.

This flight looks pretty good though.

I’m curious if the perception of delay is changed by setting these up to something in this ball park.


Minor testing with the following param changes:

  1. I do not like spin armed
  2. with these settings, the other bounce effect is still there - where I increase motor speed quickly and reduce. It sounds like the motors are getting a double increase before reducing but the motors still have a delay increasing.
  3. Automated landing does not shut off motors.

2017-01-10 11-00-53.bin (740 KB)
2017-01-10 10-57-31.bin (1.4 MB)
1 12-31-1999 6-06-14 PM.bin (1.2 MB) Indoor throttle up
2 12-31-1999 6-08-36 PM.bin (1.2 MB) Indoor flight

The log bitmask seems to have changed. RC IN and OUT are not logged, unfortunately.

Sorry about that:
2017-01-10 16-14-54.bin (367.6 KB) Throttle up - no flight
2017-01-10 16-17-55.bin (1.1 MB) Land Mode

Not had a thorough look through the logs, but the motor delay when throttling looks normal to me. The slight extra ‘twitch’ of rpm I think is because the AP sees a none 0 pitch / roll attitude and is responding to that.

The auto land delay motor shut down looks as if the ‘am landed firmly on the ground’ test is un-sure the craft is on the ground. this will delay the motor off. I see a little spike in the baro pressure drop just after touch down @17942, this is telling the AP the altitude has just increased a little. this may well delay the motor off as the AP is not convinced the craft has landed. This may be due to ground effect and prop wash. the pressure from the props may be changing the pressure on the ground which the baro detects and the AP reads as a slight altitude increase causing this.

I will do that ground effect adjustment tomorrow and report - thanks!

GND_EFFECT_COMP set to 1 - no change.
Motors continue to run on landing and not shutting off quickly.

2017-01-10 18-12-25.bin (2.4 MB)

Have you tried to reduce this yet? I see it’s still at 10.

DISARM_DELAY set to 5 - no change

1 12-31-1999 6-02-50 PM.bin (293.3 KB)

The ground effect is a physical thing not the setting. What I was trying to explain is the real air pressure changes when the copter is landed. this is perceived as a slight increase in altitude which the AP , if you like, ‘questions’ is the craft actually landed before I shut the motors down. I have seen this issue with copters with no or low landing gear as the pressure change is grater the closer the copter is to the ground.

I understand.
But again, this is with my 450, 550 and 680
Getting higher off the ground as the size increases.
However, my friends touch the ground and motors turn off instantly with the same setups.

Hi PM.Probably worth mentioning that my set up on the landing you recently posted was a bog standard stock 3.4.4 parameter set with the usual calibrations and nothing else.Taranis/X8R combo and a Pixhack 2.83.

1 Like

This needs to be linked as well to the first post.
I forgot my original post on this issue was August 8, 2016