RC4 & RC5 losing motor 2 signal

This is a long one, but I need to describe the process.
My brother and I are both using the same rig for the most part, he’s using low KV motors and longer props. I’ve got about everything you can hook up to one of these…hooked up.

Trying to put as much info out as I can here:

RCT800 Hex Frames
His 320KV 15" Prop / Mine 380kv 13" both Tarot motors.
Both using Xrotor 40A ESC, although mine are a newer revision.
6S setup with Mauch Power Modules, His using Mauch BEC and mine using Mauch switching supply.
I have tried other power modules as well, however.
Both using Pixhawk - I have 3 different board revisions 3dr original, holybro 2.4.X, and a ?? 2.4.8.
Taranis 9+ using X8Rs
Both using the Craft & Theory Telemetry modules BUT THIS IS HAPPENING ON THE OFFICIAL FW. as well
as the C&T.
Mine using Lightware SF11 Lidar, PX4Flow, minimosd
Both Have FrSky FLVSS lipo monitor & FAS-150 current monitor.
Both using that little Naza LED controller, setup on RC passthrough
Both using Tarot Gimbal setup on RC passthrough.
I’ve made a gopro controller, which is using AUX 5 & AUX 6 relay functions.
Both have video xmitter.
Both have sik radios.

I obviously like to tinker.

Anyway…I’ve now reproduced this on all 3 separate FC’s.

Using both RC versions I eventually lose motor 2 on my hex setup. I say eventually because I didn’t specifically check this after the flash, as I didn’t expect it to be happening. I’m going to test this in a bit and start reflashing from RC2 up to RC5 because I don’t recall this issue below RC4.

Power is fine (I’m using high end Fluke meters). Both are using the Mauch for board power, and a Castle 5V bec for servo rail power. Both are steady at around 5.1V

I power up, let it run through it boot process.
Press the safety switch and all ESC’s beep, then go quiet like they usually do, except for motor 2 which continues beeping with that “haven’t got a throttle signal” beep.

This first happened to me last week & being a bonehead, I tested my FC over and over for hardware issues (resistors, caps, power, etc.) and actually replaced my FC thinking it went bad. Not even thinking about the fact I’m loading test software.
While I waited on it to arrive, I tried every possible thing to get it working. It does this with nothing but power and gps, safety switch, speaker. I even tried without the speaker and gps. Tried multiple different power sources. Reverted all accessory setting to default / not there states.

So I got my new FC Weds. I went through the full mission planner setup wizard and put 3.3.3 on hooked everything up, redid all my params (fresh set, from scratch, did not load backup) and everything is fine. Flew fine.

Loaded RC5. Put it aside and started on my brothers, since the 2nd relay function doesn’t work on 3.3.3, I loaded RC5.
Then I notice when I hit the safety for arming, I hear his motor 2 beeping…
Then I boot mine up, and it’s doing the same thing.
Then I notice that my 6 position mode switch isn’t responding properly. Its reading the wrong pwm values, and modes aren’t switching.
His is doing the same, and he’s lost control of the led module (simple hi/low pwm switching on RC passthru)
We can’t get gimbals to respond.

I’m freaking out thinking I burnt up his stuff, but then I know I’m good, I’m super excessively thorough, double checking etc.

So I reload 3.3.3 on mine, and the issue is gone. Radio pwm and signal anomalies are gone. All motors arm and spin.

Any ideas? Any other things for me to try? Edit: What specifically would you like me to post log-wise?


Edit: I also wanted to add that some settings are reverting after writing changes in MP. Specifically the camera related settings, servo/relay setting. I"m also getting some random locks in the connection, where it appears to just quit responding. I’ve only noticed this when the siks are being used.

About the Channels I think you could post a disarmed log, try to switch between them and see if the rc in values are correct.

Regarding motors , how is your mot_pwm_type parameter ?

I’ll get a log together and get it posted.

The mot_type_pwm is zero. This is the oneshot setting correct? I don’t believe these are oneshot compatible.


Here’s my bro’s log - sitting in garage atm so there will be no gps lock.
I’ll dig one up from each of the others and edit this post.

I do notice the ch2 out is -1.


No…0 is normal ,1 is OneShot ,2 is OneShot125

Why dont u do ESC calibration again(did u already do that?) on one of the crafts and see what results gona be…than compare
Also I think you should load 3.4rc5 and then do all calibrations again,don’t do that in 3.3 and jump to 3.4rc5

Here’s a SS of MP, showing the missing channel. I just downgraded to RC2, still no channel 2.


Actually,on your picture,it is channel no.3…throttle…

the missing channel 2 on the right…under servo/motor out?

channel 3 is 982, and no green because there’s 0 throttle.

Re-read please.
It’s set to zero. As I said…my ESC’s don’t do oneshot, as this is the oneshot setting I have it set to zero.

In this state…esc calibration doesn’t work. So they’ve all been individually calibrated with another xmitr.

best we delete conversation about misunderstanding later…

No…0 is normal ,1 is OneShot ,2 is OneShot125

I understood u wrong…so…zero is ok…one shot still somehow experimental…
maybe this sounds silly question,but what is happening in Radio calibration screen?
Did you do ALL calibrations again in rc5?

From your last log looks like you only move Ch no. 4

and i don’t understand how RCIn and RCOut are so different

iam no log expert,just regular user,but IMU also look somehow wrong

Thanks Emin I appreciate.

I think we may be narrowing it down. I got his working by unhooking the dport connection to the xmitr.
Then one by one reconnected it, and it’s still working.

No luck on mine.

Exactly…makes no sense.

It odd that this issue isn’t present on 3.3.3.

OK…figured it out.

There are 2 issues here.

  1. is the dport/sbus. In our case, the current sensor needed to be the first in the daisy chain, from the xmitr dport.
  2. I had set RC14 to option 34 (relay 2 function). It was also set on ch_12. I changed RC14 (which is functioning as relay - Aux 6) to 0. This finally gave me channel 2 back, and armed properly.

This is still an issue imo, as this behavior doesn’t happen in 3.3.3 on either the dport stuff or the relay channel.
Whether or not the fact that 3.3.3 is apparently unable to make that relay 2 function work using pwm input has anything to do with that, I don’t know. I do know that the dport current sensor worked, and wasn’t causing this issue on 3.3.3.

I also know that we have it sorted, and I can fully control my gopro now, and everything works. I’ll go fly em in the morning.

I believe the relay 2 function is new in 3.4. The problem is that the WIKI gets updated ahead of the release causing some confusion. Also if you have a previous version you have nothing to go back on.

It would be nice if it said available as of release x. But still there is the case of the parameters changing names so what you were use to is gone and so is the documentation for it. This is were it should say deprecated as of release x use y.

This is also a problem for the GCS’s as they show features that are not available or missing.


Maybe you can re-post the steps to cause Motor-2 to stop working?
Sounds like it’s just:

  • RC12_FUNCTION = 34
  • RC14_FUNCTION = 34

and then motor 2 doesn’t work? That’s very odd.

I believe it’s:
ch12_opt - 34
(replace ch12 opt with whichever input you’re using for control - i.e. my brother’s was using ch11, still the same issue)

I’m currently at work, but I have my original FC which I replaced thinking it was faulty, still sitting there with the issue. What would you like me to post for you? PARAMS backup?

34 is motor2, so if you set RC12_FUNCTION=34 then it means you are asking for motor2 output to go to output channel 12, and not to go to the normal motor2 output channel

Ok I didn’t notice that (only found the relay function on the complete parameter list).
But the one’s I’m setting are:
ch12_opt = 34
RC_14 Function = 34.
I’m mapping my momentary swtich on the radio, to relay2 on/off. I then changed the Relay to be off on boot.
I now now RC_14 should be zero, however, I believe the behavior is still wrong - by my logic.
Looking at my old FC now, which I never changed.

If I set the brd pwm to be 4 - then Aux 5 & 6 become digital pin style relays correct?
on 3.3.3, the behavior is correct, because if you set this on that revision, the issue doesn’t occur, because the processor has mapped 54 & 55 to aux 5&6 as digital relay. So it knows in this revision, again by my logic, that servo output isn’t available on these pins - does this sound correct. (and I’m not a professional programmer, or hardware engineer, just a dude that likes to tinker with stuff).

So it seems to me some portion of the code was changed in 2 ways…the relay2 function now works, but it doesn’t lock out the servo function on it’s assigned pin.

Am I pointing in the right direction?

Here’s a link to params file:

Hi Lance,

You are confusing two different parameters. Simplifying, CH12 is for input and RC14 for output. As @tridge explained, 34 in an output parameter means you are asking motor2 to go to that output, so if you set RC14_FUNCTION to 34 you are asking the motor2 output to be put in the output 14, so it will be missing from output 2.

The reason it works in 3.3.3 is very simple: option 34 didn’t exist back then, so your motor wasn’t remapped to another output.