RC won't calibrate

Hi all,

I am an absolute beginner so please bear with me.

I have spektrum AR610 receiver and using the last Mission Planner (1.2.99).
My board is MultiWii Mega (diymulticopter.com/product.php?id_product=77) and I used arduPlane.

I attempted to do radio calibration but it seems like my board doesn’t receive the signal at all. The green bars didn’t move up or down when I moved RC sticks. But when I used the terminal for using the radio command, the numbers seems to change and are in the appropriate range.

Then, after a few attempts, now Mission Planner has problems connecting with my board. Error “No Heatbeat Packets Received” after time out. I tried to switch ports and things like that but it didn’t help.

I then tried to hook up my motors and servo with the board and they didn’t move when i moved RC sticks

I am so confused and have been rying to figure this out for weeks. Any suggestions would be greatly appreciated. Thank you so much

That looks like you will have to contact the people who made the ArduPlane port to the MultiWII for support.

Thank you for your quick respond but but I wasn’t sure what you meant. Should I contact the board manufacturer which is the diymulticopter people?

Website where i bought it from: diymulticopter.com/product.php?id_product=77
Manuals that came with it: diymulticopter.org/download/ … ga_doc.pdf