RC Not Calibrated error after flashing 3.4.3

Hi all,

Thanks for your work on 3.4. Cool list of new features and fixes.

I’ve run into an issue that I don’t know how to get past. After flashing 3.4.3, and formatting the microSD card, I can’t get past an “RC Not Calibrated” error. I reflashed in an attempt to fix an unrelated problem. That is why I also formatted the uSD.

I’ve performed RC cal several times. I’ve reflashed. I’ve tried changing power sources. I’ve check supply voltages. I’ve done everything that I can think of, short of reverting back to 3.3.2. I must be missing something.

Any thoughts or advice are much appreciated.


I have now reverted to 3.3.2. I had also disabled the prearm check. Still no joy. I’m stumped.

What is checked in pre-arm for RC:

  • throttle min and max calibrated
  • pitch, roll, throttle and yaw have min <= 1300 and max >= 1700
  • pitch, roll and yaw have trim between 1300 and 1700

If you think that you have all of this correctly set then please share a log.


I should have stated that I’ve checked all of those things already.

I’ll see if I can figure out how to share a log.

OK. Here’s a log. I noticed that the timestamp is way off. I’m not sure what that’s about.

I also found that with 3.3.2, if I disable ALL prearm checks, not just RC, that I can get a green status LED.

All your RC values are the same, which isn’t very normal. I’m 99% sure that your problem is that your throttle min/max values are still 1100 and 1900 and most probably they have never been saved - and so the system detects it as not configured. If 1100/1900 is really your configured values you need to save a different value and then change back.

Those aren’t my calibration values. Weird. Here are the values that I see, and they stick through a power cycle. RC1 isn’t shown, but is in the same range.

That is weird. Try to turn LOG_DISARMED on and get another log. What I saw in the log you posted is consistent with the error you get.

I don’t see a LOG_DISARMED parameter in the list. Is that a feature of later firmware, or should I be able to find it elsewhere?

BTW - Thank you very much for troubleshooting this with me. The help is much appreciated.

Update - Went for a walk. Returned to a working scenario. When I left I had even more errors, EKF problems, etc. Now the FC will arm, and I get a flashing green status LED.

I have no idea what made the difference. However, I have accomplished my original goal of reflashing the FC and formatting the uSD.

There is still the mystery of why I need to have the RC prearm check disabled.

OXINARF, If you want to chase this problem further, for your own curiosity, I’ll be happy to participate. For my purposes, it looks like I could let this inquiry go.

Thank you again.


I may have spoken too soon. More weird behavior. I’ll try to get more info before spamming this thread any more.

It is present in 3.4.

I have no idea what can be wrong to be honest.

I think I found the problem.

At the end of the day, yesterday, I was seeing every prearm error and hardware failure error imaginable. The situation was spiraling out of control. In desperation I re-seated the uSD card. The problems cleared up immediately.

I suspect that when I first removed the uSD to format it, that I messed up the flight controller’s chi. :slight_smile: I am not under the impression that the FC’s parameter list is stored on the uSD, so I don’t know why a bad connection to the card would cause so many problems. Am I mistaken in this belief?

I still don’t understand why the FC application doesn’t think RC calibration has been performed, but disabling the RC Calibration prearm check is now working. Since I know that I have calibrated, I think I can live with this work-around.

So, in the end, my issues have nothing to do with accidentally upgrading to 3.4.3. That was just a coincidence. I might try the upgrade again later, but for today I need to get on with my flight testing without introducing new varables.

Many thanks for the individual help!


No, you are correct. I’m not sure why a badly inserted SD card would cause those issues, but NuttX (the OS below ArduPilot in Pixhawk) has moods sometimes.

If you share a new log I can look at it, although the conditions I mentioned before are the only things that are checked. Flying with disabled pre-arm checks isn’t advised at all, I understand you needed to fly, but you should try to get to the bottom of this as soon as possible.

Funny that you should mention getting to the bottom of it. It turns out that even the uSD card was not the problem, as I started having problems again this afternoon.

I went ahead and upgraded the firmware to 3.4.3 and voila, the problem once again seems to be fixed.

I was able to fly today, and at least perform the testing that I wanted to.

I understand about the risk of flying without pre-arm checks. Thank you for the warning. I have a pile of technical issues to work out. I’ll just add that one!

Whether or not my issues have anything to do with flashing 3.4.3, I have no idea at this point. I have a flyable aircraft again. That is good enough for the moment.

I’ve linked another log, from my second flight today. I would be grateful for your comments.


Hi Chris,

I’m sorry for not getting back to you for so long. Things just pilled up and I missed it.

How have it been going? Have you re-enabled the pre-arm checks?

Hi Francisco,

Thank you for following up on this issue.

My last flight had only the RC Calibration pre-arm check disabled. That seems to work well enough. Since upgrading to 3.4.3 and staying there, I haven’t had any more weird issues.

I haven’t been able to fly since the weather got cold. The aircraft has low-temp issues with the electronics. I need to find better quality stuff.