RC_IN on orange cube plus

Hello I have a query connecting my receiver to Cube Orange Plus.

I am using Cube Orange Plus with Airbot mini carrier board, Link.

As shown in the diagram, 4th pin on the top from right is RC_IN to connect my receiver. However, this is not working. Whenever, I press bind DSMX on my mission planner for binding my receiver to the transmitter, at first red light in the receiver should glow which is not happening.

Moreover, if I do the same process with Cube Orange ( attached on Airbot mini carrier board), there is no problem with the receiver. As soon as I select bind on my mission planner, the red light on receiver starts glowing.

I am not sure why this is happening? Is it because some wirings in cube orange plus are different as compared to cube orange?

Also, what is solution to this? How can I configure any other pin as my RC_IN to use it on cube orange plus successfully.

Prarthana Sigedar

As shown here, you need to make a solder bridge to enable Spektrum RC. It’s a feature of the carrier board, not the Cube.