RC Example sketches don't work

I’m using Pixhawk 2.4.8 with Arducopter 4.1.2

  1. If I upload Arducopter (full code), with my RC receiver SBUS connected, everything works fine. I can see the signals as I move the Transmitter stick.
  2. If I run RCInput, RC_Channel, RCInputToRCOuput examples, the codes compile correctly as they are, and run when my transmitter is off. However, when I turn it on, it completely stops spitting out anything on the serial, and basically freezes the serial port entirely. I have to actually disconnect and connect it back so that is does something reasonable. After this, again, I can upload normal arducopter and see the signals perfectly, but the RC examples don’t run, all other examples run fine.

Update to ArduCopter 4.4.0 and retest, it might already have been fixed.

Thanks for the prompt reply. I did upgrade it to 4.4.0 and still the same problem above.

Then open a GitHub - ArduPilot/ardupilot: ArduPlane, ArduCopter, ArduRover, ArduSub source issue with as much details as possible.

How are you powering the pixhawk?

The pixhawk is connected to my Laptop USB port. It works fine as is when I’m running Aeducopter_4.4.0 It’s the RC example sketches I’m having problem with as stated in my previous post above.