RC Channel Override not working

I want create my own GCS for my final project, but I have a problem to sending rc_channel_override command to control my copter via mavlink from arduino to APM 2.8
I can send request_data_steam and command_long fine, but when I tried to send rc_channel_override command the copter didn’t give any response.

Here is my code :

When I press ‘1’ the copter respond and start to arming, after that I tried to send rc_channel_override command by pressing ‘2’ - ‘5’ but there’s no response.

I read data stream and I found that when I send arming command the copter respond by sending FD(HEX)/253(DEC) message, but when i send rc_channel_override command there’s no respond at all. So I assume that the rc_channel_override is ignored. Can someone help me solve this problem, what I’m missing here?

Here my data stream :

Hello Dikko,
How are you doing? I hope you have been able to move forward with this problem.
At this moment I am facing the same problem. Do you have any advice or evidence that you have done to prove or discard this option?
If you have not been able to advance hopefully we can help each others with our experiences.

Since this is still ranking at google:
I overcame similar problems with ArduCopter by using MANUAL_CONTROL.
But there are still some traps waiting:

  • If the senders system id does not match the one set by the ardupilot parameter SYSID_MYGCS, the message will be quietly rejected (by default system_id = 255 will work).
  • Also, the target system ID in the message is checked and has to match the FCs system ID (ok that should go without saying).
  • One last check that might silently reject everything is if the input for z (thrust is < 0)

details here:

I guess the RC_CHANNEL_OVERRIDE has the same checks.