Raspberry Pi 4 with PixHawk 2.4.8 Drone MavLink MAV> 1 Down Error


I am new to the discussion board so I hope I ask this properly. I am working on controlling a Pixhawk 2.4.8 using a Raspberry Pi 4 and I have followed almost all online instructions via multiple sources (Currently following https://www.youtube.com/watch?v=kB9YyG2V-nA) and still keep running into the issue below. I am at a loss for how to fix this issue. I have all source Baud Rates set to 57600 and downloaded the the Copter 4.0.5 in Mission Planner. Any guidance would be very helpful thanks in advance!

1 Like

UPDATE: I now rechecked the wiring and MissionPlanner settings and when I enter the command:
sudo -s
mavproxy.py --master=/dev/ttyAMA0 --baudrate 921600 --aircraft MyCopter

I now get:
Waiting for heartbeat from /dev/ttyAMA0
It will stay on this until it CTRL+C

Any guidance would be greatly appreciated!