Raspberry Pi 3, Qt 5.6

Good evening. I wanted to get the latest APM Planner compiled for a Raspberry Pi. In 2014 I used a slightly older version to allow me to use QT4. I have had problems compiling so I moved to compiling Qt 5.6 from scratch and working on that method. I got a long way into the code and compile but I have got stuck this time.

quaadler32.cpp:(.text+0x1c): undefined reference to z_adler32' build-release/obj/quaadler32.o: In functionQuaAdler32::calculate(QByteArray const&)’:

And a number of other related problems with quazip.

Long story short… I am looking for some co-conspirators to get the Pi version up to date, and perhaps even get a binary download for Pi2/Pi3.


1 Like

If you would like to get APM Planner 2 up and running quickly on the Pi2/3, I would suggest using the Ubuntu Mate image and installing apm_planner2_latest_wily_armhf.dep from http://firmware.ardupilot.org/Tools/APMPlanner/.

I plan on creating a package for Raspbian, however, I’m going to wait a bit until the bugs get worked out and OpenGL goes from experimental to beta or something that doesn’t make my head hurt.

Thanks carpy. I will try that out today. Appreciate.

OK so close. Got Ubuntu Mate installed and updated to latest 16.04 version. Installed Qt Packages and APM Planner debian as above. And unfortunately each time I run it I get a segment fault. But now I have the Qt code I might try compiling APM Planner from source.

FYI. Problem with binary in package and Raspberry Pi seems to be to do with Qt Platform. If I use nothing I get a core dump early. If I use “-platform eglfs” I get could not open egl display core dump. But if I use “-platform linuxfb” I get the splash screen appearing, all the usual debugging information loading serial ports etc. Then a dump because it is trying to use a QSurfaceFormat which works only on Open GP.

On a compile front I am stuck again on qt some missing Qt Package. I can’t find the DEV version of the following: Project ERROR: Unknown module(s) in QT: quick qml quickwidgets


Ok, let me compile it and I will report back soon. The deb package I pointed you at was compiled for Ubuntu Mate 15.10.3 (Wily)–I didn’t realize 16.04 was out.

Ubuntu Mate 16.04 APM Planner 2 2.0.20 here, https://www.dropbox.com/sh/6tx02zn95yktucy/AABaCuoi1a2_GjUNALeWMoKia?dl=0
MD5: f8d8dcd38d1b889e56a55c7363322f1e


Awesome thank you. I got my compile to work too. Just downloading yours to make sure it works. But I am really glad I got my compile to work because I want to work on a smaller screen view. I have a nice ground station using daylight readable screens, low resolution, and it currently doesn’t fit.


Hello Guys could someone of you both share the physical image for using APM Planner on Unbuntu 16.04 ?
I am very new to linux and did not succeed in performing above mentionned instructions.
I am using a Raspberry Pi 3, I hope this will be fine with your image!

Thousand thanks in advance!!!

If I understand what you are asking for, you can download 16.04 from here:

1 Like

Thanks Carpy for the reply.
I indeed successfully managed to get Ubuntu Mate 16.04 installed on my RPi3
The issue is now to install APM Planner on my running Ubuntu. I used the file communicated above but it showed not to work during installation --> starts installing and then “unable to download package” whereas I actually am connected to internet.
Therefore I just would like to download a “ready to flash” image of Ubuntu 16.04 + APM Planner already installed (a “.img” file).
All links or procedures I have been trying never worked, this is just becoming a nightmare for me!!
Thanks for your help

Sorry for my “newbiness” but I finally succeeded in installing APM Planner 2 after re-installation of Ubuntu… It only needed a little “sudo apt-get update” to update the core librairies… after that I could launch the .deb without any problem.
Thanks very much Carpy you made my day!!
I am now a happy user of APM on my RPi3, some tuning again in front of me but everything should be ok from now.Guillaume

1 Like

Perfect–excellent to hear.

An image for newbies might be worth adding.
My requirements for the Pi are an old groundstation (well not that old) that I built in 2014 for using in Antarctica which use the Pixel Qi 10". The screens are amazing and work great outside.

APM Planner back then would fix into the screen space of 1024x600 - now it won’t, and the default MATE config also won’t allow me to hide the menu bar and bottom bar.

So I have now compiled APM Planner on 16.04 and working through some configuration options for APM Planner for this smaller screen.

Therefore, I have an image that contains all the build tools - so fairly large. If that is interesting to people?


1 Like

I would say so Scott. I had a few people ask for an image for 2.0.18. Also, a few people having issues for smaller screens < 1024x768, so if you have that figured out on the Pi…

1 Like

Hi carpy thanks for the Ubuntu Mate 16.04 APM Planner package … it works right out of the box. I just needed to install the following dependencies:

sudo apt-get install libqt5opengl5 libqt5qml5 libqt5quick5 libqt5script5 libqt5script5 libqt5serialport5 libqt5svg5 libqt5test5 libsdl2-2.0-0 qtdeclarative5-qtquick2-plugin qml-module-qtquick2 libdouble-conversion1v5 libsndio6.1

However today I found some time to set up the Build environment. Under Ubuntu Mate 16.04 Qt 5.5.1 is available. So for all who are planning to do the same, I installed the following packages:

sudo apt-get install qt5-default qtdeclarative5-dev libqt5opengl5-dev libqt5svg5-dev libqt5extserialport-dev libqt5serialport5-dev libqt5svg5-dev libqt5gstreamer-dev qtscript5-dev libsdl2-dev libsndfile1-dev

After that APM planner could be build out of the Git repository without problems. Now I can continue with building of my Pi powered ground station.

1 Like

Yes, definitely interested!
I indeed was prevented using APM Planner 2.0 on Ubuntu Mate 16.04 due to my small screen, an Official 7’’ Touchscreen. I struggled to change its resolution without success…
So if you have a solution for smaller screens yes I jump on it! :slight_smile:
Would you have a Dropbox address or similar for me to download a disk image?
Thanks in advance

I got my Pi3 yesterday, and want to use it as GCS. Thanks for sharing this.

1 Like

APM Planner 2.0.23-rc1 available for Raspberry Pi 2/3, built with Qt 5.5.1.

can any one help me out in installing mission planner for arduopilot2.6 in raspberry pi. i am using noobs os in it thank you in advance