Rangefinder not showing in Mission Planner Data

Hello and Good day!

Curious why my rangefinder is not showing in my Data on Mission Planner. I tried doing the documentaries but there’s just nothing showing up.

My aim is to send an ultrasonic by PWM result to the PixHawk using Arduino.
I followed this tutorial: Part#4:How to send signal Ultrasonic by PWM to pixhawk with Using Arduino - YouTube
Also tried following this documentation: HC-SR04 Sonar Rangefinder — Copter documentation

But both shows none even if I tried rebooting my PixHawk. Can anyone help? Thanks!

Hi @johnmeeel ,

You could try this sonar, it works connected directly to the FC and doesn’t cost much. The range is small but it still works. Here you can find info and some videos.


Could try using sonar but my goal was to try a different sensor. I was trying to test if ultrasonic using Arduino is possible because im gonna try another sensor if it can yield the same output.
The sensor I’m going to use is Hx711 load cell module